Main Site Documentation

ENC28 problem


#1

Today I received the new ENC28 v1.1. I attached it to my Hydra and connected the power supply to the UDP DP client. And the network leds come on immediately.

Same problem as with the ENC28 v1.0, I’m unable to ping this device.
I updated the firmware again and erased data with SDCard and boot.bin.
After update I opened MFDEPLOY.exe and set the IP to 192.168.0.100.
I opened cmd and ping 192.168.0.100:

What can still be the problem? I attached both with a cross cable and set the ip manually on my laptop…


#2

MFDEPLOY settings:


#3

what is the ip configuration of your computer?


#4

my network settings on laptop (I tried 2 different laptops with firewall and antivirus disabled / not installed)


#5

Hi krikke999,

What happens if you change your gateway address setting to 192.168.0.1?

Chris


#6

Also if you deploy a simple program, switching some relais. Should it automatic start when you deploy in release, disconnect the usb cable (powered with external power supply + USB DP Client)
The code only runs when I start it from Visual Studio in Debug.

I also updated to the latest network firmware for Hydra…


#7

still no go… with gateway to 192.168.0.1
Even with cross cable directly connected to laptop doesn’t work


#8

I was using port 4 on the Hydra for the ENC28 module, now I switched to port 3 and now it works!


#9

You have to be careful with windows 7 when you make a direct connection between the PC’s Ethernet port and another device like FEZ Hydra. Make sure that you do NOT set a default gateway at the PC side or windows will block this Ethernet connection.


#10

Hi,

I have a similar problem with my FEZ Raptor + ENC28 v1.1. Here is my settings

Device
192.168.0.213
255.255.255.0
192.168.0.1
DHCP: OFF

Laptop
192.168.0.105
255.255.255.0
192.168.0.1

Firewall is off… any idea why ping doesnt work?


#11

Hi Durnek60, welcome to the forum. I’d start your own thread, this one is 2 years old and unlikely to have any value to you from a history perspective.


#12

Dear Brett,

Thank you, I am making a new thread, see u there! :wink: