Main Site Documentation

EMX Update failure (Loader unknown device)


#1

Before I permanently bin my FEZ Spider kit, I wonder if anyone can help?
Win 7 Pro 64 + Spider Tinybootloader V4.1.60, EMX V 4.1.8.0 connected via powered USB hub.
Ready for the Winter, I powered up my Fez Spider, the previously loaded program worked OK, I tried to load a new version , no joy, USB connection reported as unknown device. I decided to move to the newer 4.2 SDK – same result. After some investigation, I found that Windows remembers the EMX as an unknown device every time. It seems there are two device drivers one for the TinyBootLoader and one for the EMX loader. With the switches on the EMX set for TinyBootLoader and persuading Windows to reinstall the drivers, I was able to get the GHI NetMF debug driver to install when resetting the EMX boaard. This might have been promising except that I have found no software that will perform a file transfer through the USB driver. FezConfig uses the Loader driver which has the unknown device problem, and TinyTerm wont configure for a usb connection (I have no COM ports, anyway). It seems that the EMX loader 4.1.8.0 USB protocol in some way does not suit the windows USB interface (this uses an Intel ICH9 Family USB Universal Host Controller). I have a J11D LAN module as part of the Spider kit, but I dont know if the loader version would work through that (e.g. with Fez Config). Unless someone can suggest a way forward, I am stuck with a useless Fez Spider kit.


#2

The loader itself needs to be updated. There are instructions on how to do that using FEZConfig.

Welcome to the forum!

Edit:

Here is the link:
https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families


#3

@ John26 - I would suggest that you uninstall all the GHI components including the USB drivers. Then install the latest release. Once that is done, attach the spider to a different USB 2.0 port than the one you are currently using.


#4

Thank you for your reply #1. I have tried to follow this procedure given in your reference a number of times. As I have stated in my question, either the Loader USB driver causes an unknown device problem OR I can get the GHI .NET Micro Framework USB debugging Interface to install, but TeraTerm cannot see a COM port. Hence I cannot move forward, neither FEZConfig nor TeraTerm offer a way to load new firmware.

Thank you for your reply #2. I have effectively done this by installing for the 4.2 SDK (I was using 4.1). If all else fails I will try a complete uninstall and reinstall before giving up, but at the moment this doesn’t look as though it would change the problem I am having.


#5

So can you show us screen shots of your Device Manager in the different states? Firstly when you boot normally and the device is in regular run mode for netmf (you should see the debuggable .netmf device) and then when you manually boot into bootloader mode. If you can see devices there that are not recognised, please open their driver information and screen shot that too.

Can you also tell us if your previous use of the device was on this PC or a different one? Have you ever used this PC successfully?

Do you have an older USB 1.1 hub anywhere? If you add that between your PC and the Spider, does anything change?


#6

This may help https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting