Main Site Documentation

EMX Stuffed Ethernet Interface


#1

Hi,

I am having issues with custom hardware I have built for the EMX. All functionallity on my board works apart from the Ethernet interface.

The Ethernet interface originally worked, getting full speed comms between the device and a windows service. It then stopped working without any change in the code. Then for some reason it started working again. The hardware had not been changed or moved. The device had been on the whole time. Since then it has stopped working again and it will not come back ???

When the Ethernet stops working, I have noticed the following:
[ulist]The activity LED on my board flashes, but the activity LED on the switch does not. I have tried multiple ports/switches etc.[/ulist]
[ulist]All other functionallity on the EMX is OK, Comms, SPI, SD, GPIO etc.[/ulist]
[ulist]Erasing the bootloader/tinybooter, and installing fresh firmware and user code has no effect.[/ulist]
[ulist]The exact same code works fine on an EMX development kit.[/ulist]

The program hangs at the following code, before it throws an exception:

NetworkInterface networkInterface = NetworkInterface.GetAllNetworkInterfaces()[0];

try
{
  networkInterface.EnableDhcp();
}
catch (Exception ex)
{
  Throws exception here
}

I have to assume that the EMX module is stuffed, unless anyone can offer any other suggestions?


#2

Check the Ethernet cable (how long is it?) and try different switch port.
Connect id using a crossover cable directly to your PC.

The excpetion you are getting is just normal. since the device is failing to connect to the network then it is not able to connect with the DHCP server and to get a DHCP lease.


#3

Funny, I have problem with ethernet now as well:(

Background
-I have now 8 devices (all the same construction). Only one of them is faulty
-This faulty one did work for month or so and stopped last week. (another devices works longer)
-All other interfaces work fine on “faulty” device (I2C, COM1-4, USB, SDCARD)
-I use static IP, no changes in hw/sw

Behaviour:
Initially 100M LED lights, link LED does not

When I connect ethernet cable to my notebook (EMX-notebook):
-100M LED lights, link LED blinks in bursts (2-3sec rapid blinking/2-3sec dark)
-After several such bursts 100M LED get dark, link LED lights. Only at this moment notebook reports “connected 10M speed”)
-When I try ping link LED is blinking, I have no response to PING

When I connect ethernet cable to another notebook or switch:
-100M LED lights, link LED blinks rapidly
-notebook/switch immediatelly repors “connected 100M”
-ping does not work

Additional info
Now ethernet is completly dead. About day before current state I found that there is not ethernet communication. I try reset -> no result (several times). Power cycle fixed communication. It works for another day. Power cycle fixed it for several minutes, now there is no way to make it working.

Looks to me like HW issue similar to D Procter’s one >:( Any idea what could be reason? Any idea how to fix it? Any idea what to do to prevent such fault (on another device) in the future?
Best regards,
Marek


#4

You network settings maybe incorrect or corrupted. Enter the GHI loader and completely erase everything (E command) on both your device, the one you think is good and the one you think is faulty. Then load everything back on both and test.


#5

Tried running my custom EMX hardware on the static IP Address, still no luck. The same code works on the EMX development kit plugged into the same Ethernet port on the switch.

Ethernet Cable is 0.5m. The switch is unmanaged. I have tried communication between two laptops on both the ports I am testing with.

As a side note, the Enternet on the device worked for about 1 week, then stopped working for one day, then started working again for one day, then stopped working all together.This is not an issue with the device talking to a DHCP server.

I have to agree with m-land that this appears to be a HW problem. :’(

I have fully erased and reinstalled all ‘low level to user code’ on the device using the EMX Updater.


#6

Did you use the same magjack?


#7

What MAC addresses are you guys using on those device? Is more than one EMX connected to the same network?


#8

All my devices use the same magjack (J1011…)
Each device has unique MAC - set based on the sticker

In production site there are multiple EMX devices connected to the same switch. However when testing faulty device it is only EMX on the switch or it is connected directly to notebook (I use normal and croseover cable - no difference)
m-land


#9

I use a different mag jack, Tyco Electronics 1-6605834-1

I need it for the PoE pass through functionality. I doubt it would be the Mag-Jack though, because the device worked for a while before it went faulty. If the magnetics were incorrect, surely it wouldn’t work at all.


#10

What if an error in your PoE caused some damage to the circuit?


#11

I suppose it’s a possibility, though my bespoke hardware uses a silver telecom Poe module, which completely isolates the PoE voltage from the logic voltage. Beyond this my circuit has overvolt and over current protection, and decoupling caps close to the emx to stabilise the logic voltage, which is generated by a POL module.

I’m more concerned that my company is about to do a small production run of these boards, and I need to make sure this issue won’t repeat itself.


#12

And there is no PoE in my case. Just magjack connected directly to EMX


#13

I am not sure how we can assist further but please contact GHI directly through email or phone.


#14

I personally would have thought that a failure like this, where it worked and then stopped working on one board only, would be something like a failed solder joint.


#15

I have checked the boards for shorts and open circuits. Unless the board was damaged during the initial prototyping I am at a loss for what is causing this fault. Just have to wait and see if the professionally assembled boards work any better.