EMX: SD compatibilities issues

Hi everyone

We 're facing some troubles while trying to set up product based on EMX module and SD card.

We used to log data on microsdhc card from samsung. These are 4GB class 4 with transfer speed of 24MB/s. Recently we bought a set of 8GB microsdhc 1 of class 4 from the same manufacturer and we have a lot of problem. None of them can be written by the EMX board. Some of them can be read. Other were fine for the first write read phase but then become unreadable, for these lasts even windows on desktop recognize them as unfiormatted (and can’t format them)…

Is there’s any rule in choosing SD/µSD for GHI products?

Edit

Using non-UHS version card seems ok no matter the size is… Does this mean that EMX does not support Ultra High Speed SD card?

Our rule for some time has been “Not Kingston”, based on client feedback.
We’ve used Transcend and Sandisk with no reported problems to date.

I believe the problem may lie with the SD power supply on the EMX coming via the module rather than direct from the rail. Some cards draw too much current at times and suffer intermittent failure. This was probably done so that EMX systems can save power by disabling the card supply. On the G120 this method isn’t used, and the card connects directly to the supply rail.

We used to have lot of troubles with SD card but since several months all seemed to be better until last week when we received new sd card. We have a 22µF capacitor between SD_power and ground. It could be interesting to have the GHI point of view about this. The problem will be to found non UHS µSD in the future…

SD cards are very tricky and picky. IF you send us one of your cards, we will gladly look into it for you.

The bad thing is that teh second card have worked during an hour or two. Then EMX was not able to write but was able to read. I finally format it on windows and it becomes unresponsive. Sending it to you will therefore be useless.

@ leforban -

I have no idea but I have used the ‘official’ SD format on some odd cards with success…

See:SD Association

https://www.sdcard.org/downloads/formatter_4/eula_windows/

I’ve used many different brand with success except Kingston that doesn’t work at all.
I noted that also cluster size during format is important. The rule of thumb I use is to format in windows with cluster size of 512-1024kb if possible.

At some point I hade some troubles and compared some cards but…
https://www.ghielectronics.com/community/forum/topic?id=11382&page=3

I use scandisk for my µSD32Gb at the moment and transend industrial USB memory on the USB client interface.

New insight:
The 8GB non UHS1 that was working yesterday had some troubles at the end of the day. Now it does not work properly today. The firts three attemps was ok buth it starts to have problem in writing again. I have check with the 4GB non UHS1 and all is fine.

The bad thing is that there’s no exception!!! the board reboot while writing and that’s all…

Now that I know that this card was working yesterday. I will try to see if something is wrong in the design (maybe EMI or bad component).

@ leforban - As Gus mentioned, the uSD cards can be a bit flakey. I’ve never seen the problems our client reports with the Kingston cards while testing in the workshop, and the ones they have returned as faulty have worked for me. But as they report no problems with Transcend and Sandisk, I’ll try and stick to those.

I did have a problem with a new EMX module, it just would’t talk to the uSD at all. In testing I found that the EMX card power supply output wasn’t driving properly, from memory it was around 2.1V tops. I fixed that board by cutting the track and tying the uSD power to the 3.3V rail, but it does concern me that some other modules may be marginal.

I think I’ve found the pb. In fact, we have place a poly fuse on 3.3 Power rail. Then this suppy the MCP130-315 supervisor circuit. In fact we have 3.3V at the output of the linear reulator. Then 3.17V after the polyfuse and when the card is in writing cycle the voltage seel to drop down the threshold and reset the board. That is why we do not notice any exception from the debugger. Grrrr this is the second time that I chose a wrong polyfuse… even if I have oversized it the voltage drop is too big and detected by the supervisor.