EMX Development System update

I have a EMX Development System which I last updated on the 29 Nov 2012. I was installing a updated version of 4.2 to overcome my RS21 problem. I now have a tinybooter version of and a EMX version of I note that the download on GHI install page release notes list a version of If I try to update the EMX Development System board I get a message Cannot connect to the device. Please advise how I can establish now that everything is out of sync.

you’re going to have to tell us what devices are visible in your device manager, at different points in the firmware update cycle.

Thank you for the reply Brett. I have attached two Devices Manager screens:
The install claims it cannot find the driver. Can the EMX Development System still use the current drivers?

Looks like you are doing all correctly. So windows is not accepting those drivers? Did you try to load the loader drivers? Maybe EMX is in loader mode.

I have tried on two computers. What is loader mode? Is it described in the EMX User Manual? EMX is showing “EMX Version Debug: USB1”. Was there a period when EMX was and “Tinybooter V4.2.0.0 EMX Build Date: Oct 24 2012”? Perhaps when I installed on 24 October that’s when the damage was done to EMX. Note the version of Tinybooter which should have been Since then I tried to upgrade to V4.2.7.0. The pc I have shown above (Device Manager) had never previously had GHI SDK installed --> I tried EMX V4.1.8.0 Tinybooter V4.1.6.0 as I am struggling with wifi 4.2 on another PC and may need to go backwards… Any help would be much appreciated. Regards, Kevin.

Aha! I know what is going on now. Please follow the updater or the wiki instructions and fully update your device please. Starting by holding up, select and down buttons to enter the loader mode and erase all.

I am in tinyboot mode. How do I “erase all”?

Tinybooter is not what you need http://wiki.tinyclr.com/index.php?title=Firmware_Update_EMX

Ok I ran the “EMX Updater” selected “Erase all” clicked “Update” getting Log: Connecting to device… Cannot connect to the device!
Under “Device Manager” Other Devices I still have “EMX” which has no driver.
The “GHI NETMF USB Drivers” is installed under “GHI Electronics” under “Program Files”. If I try to install the driver (as described above) get message "Windows could not find driver software for your device."
I need the interface up and running to access EMX with the Updater?

You are still skipping the first step. Please hold 3 buttons and reset the board. If you see anything on the display, you did not hold the buttons right. From here you need to load the USB loader drivers. This should be explained on wiki.

Thanks Gus. I now know the difference between EMX screen, Tinybooter screen and a white clear screen. From the pictures below you can see that the GHI driver loaded during the clear screen without me doing anything. Next I ran the updater and the Tinybooter now has V4.1.6.0 which is correct. Then the reboot failed (see log from updater). The EMX seems stuck in TinyBoot Mode.

ok this is good, what do you see on the screen after you reset?

I had this problem last week. Make sure you have .Net 3.5 SP1 installed, then reinstall everything from GHI.

I believe the installer has an unhandled exception if the 3.5 framework is not installed, and thats why the files are missing when the updater is started.

I have .NET 4.0 full installed and thought this covered 3.5 Programs listed include 1.1 and 4.0

Meanwhile it seems that the driver GHI Boot Loader Interface comes and goes hence the next photo showing the system deciding to load it again.
I tried the alternative approach using teraterm and next photo shows log. I assume that is the end?
I now need to move from the clear screen to the tinybooter screen but cant get it to respond to up down reset buttons. Did the tiny update complete?

I think that you next need to go into MFDeploy and send the two image files across for the firmware… if you reboot now you should still stay in bootloader mode IIRC.

I powered down and up and I still have a white screen. In MFdeploy when I select USB the second field has nothing in it (no EMX_EMX).
Perhaps I need to disconnect everything from the motherboard? Most has no power but perhaps I need a bare motherboard?
Regards Kevin

Device Manager. Always your friend. Tell us what he sees :slight_smile:

When I press the reset button on the EMX I get the good old Win 7 trumpet.
Here is a photo of the device manager right now. Its holding the GHI driver even when I disconnect the USB.
Perhaps I need a fresh download of GHI SDK. Perhaps the files are corrupt.

it’s in GHI bootloader mode. So that means it doesn’t have a valid tinybooter file (I think, from reading http://wiki.tinyclr.com/index.php?title=Firmware_Update_EMX anyhow)

I would go back to the manual instructions and start at step 11, using COM4 which is the port that appears above. Press V and confirm the version and go thru the next steps.