Main Site Documentation

Domino USB Detection Win7


#1

With much anticipation my shiny new domino has finally arrived :slight_smile:

However i seem to be very stuck, currently holding down the loader button and plug the board into the usb port on my pc however windows doesn`t seem to know i have plugged it in, therefore i cant load the drivers and continue on to the firmware via teraterm etc etc.

Currently when i plug in the power led is on full and the led1 is is on kinda half the brightness.

I checked windows out with a different usb device it hadn`t seen before and that work so the usb port on the pc is ok.

Any ideas ??
thanks


#2

Just hold the button while plugging. Once its plugged in release button.


#3

errmm nope, not a sausage which is kinda the krux of the whole issue


#4

I’m using Windows 7. I just plugged it in, no button pushing required, when the dialog popped up as Windows was trying to find the driver I stopped it and redirected it to the proper driver. If you’ve goofed things up you’ll have to find the Domino in the Device manager and use the ‘Update Driver’ button to load the correct driver.


#5

Lets do this in steps…

(do not press any buttons)
When you plug domino to your PC using USB cable, it is detected and windows load the debugging driver, correct?

When you open MFDeploy, you can see USBizi under USB and you can ping the device, right?

Now, hold reset button down and keep holding, windows will make a disconnect noise, correct? And also USBizi disappears from MFDeploy, correct?

Keep holding reset button and now press and hold LDR button…keep on holding LDR button down and now release reset. Windows now should ask for new drivers, the loader drivers, correct? You are still holding LRD button down…do you see USBizi in MFDeploy? You shouldn’t


#6

As Jeff_Birt said, check your device manager for your domino board. Update your driver there.
Probably windows messed something up and there is a miss-match. After updating your driver it should be fine.

Be sure to try chimp’s way first.

good luck.


#7

When you plug domino to your PC using USB cable, it is detected and windows load the debugging driver, correct? “NOPE” i can add these driver manually but i get the following warning in device manager. This device cannot start. (Code 10).

When you open MFDeploy, you can see USBizi under USB and you can ping the device, right? “NOPE” no devices seen in mfdeploy.


#8

I think you are trying to load the loader drivers on the firmware debugging interface!

Do not press any buttons, power up the device and load these driver
C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.0 SDK\USB Drivers\GHI_NETMF_Interface

Then open MFDeploy and try to ping the device

If this works then we can go to the next stage


#9

That is exactly the driver and method i have manually tried resulting in the device showing up in the device manager with the code 10 error. the device does not show in mfdeploy. the drivers i am using where downloaded from the latest sdk posted link on the website.

i wonder if it is a issue with x86 win7 and compatibility with the driver ?


#10

no known problems with any version of windows.

One last guess, your PC USB power (or the USB HUB) is too weak to power FEZ!

Get a power pack and power FEZ then plug in the USB cable. Does it work this time?

Do not try anything with loader drivers or LDR button till you can ping the device from MFDeploy and use the drivers pointed earlier.

If still no luck, you may want to try the board on another computer too.


#11

I’m using Win7 32bit on this PC with FEZ with no issues.


#12

I am using the FEZ on Win7 64 with no issues.


#13

i tried with a additional power supply, this didnt help so ill wait till monday and try plugging it into my works laptop. im pretty sure its not gonna make much difference tbh but ill try on monday, that being said all the replies are very much appreciated.


#14

Last question, when you plug the device to your PC, does windows ask for drivers?

Now I am thinking what if your board somehow didn’t have firmware on it! Did you try to load the loader drivers instead?


#15

Windows never once asked for any drivers when the board was plugged in, in fact it never even beeped to acknowledge a device had actually been plugged in.

I did try a usb camera the pc hadnt seen before in the same usb port on the pc just to check the pc was working and it detected that straight away so im pretty certain the pc in itself is ok.

I have a xp pro machine that i use for writing software at work i`ll try that on monday.

Im not overly concerned at the moment im sure somehow well get it working, I have alot plans up my sleeve for the USBizi chipset, and im certainly not throwing the towel in, over a minor solvable issue :slight_smile:


#16

All boards we ship have a pre-loaded program to blink the LED and you said earlier that the LED doesn’t blink!

Where did you order your FEZ? Directly from this website?


#17

Thats correct, on first powerup and ever since the power led is on full and the led1 is on but very faint, and yes i ordered direct through this website. if i remember correctly the checkout was through the ghi website


#18

Please send an email to GHI directly and provide a link to this post. We will take care of this so no worries :slight_smile:


#19

Have you tried a different USB cable (you want a USB-A to USB mini-B). I have seen flaky USB cables wreak havoc, creaking very hard to diagnose problems.


#20

If he used power source but no blinking LED on anew board then something is not right!

If you have a volt meter, measure the 5V and 3.3V you have on the female pins