Do I have a broken ENC28?

I have had my ENC28 (v1.1) for awhile now, but it has not had much use since I have mostly used the Spider with the J11D module for networking. Now I have tried the ENC28 on my Hydra and Cerb, both with the Ethernet Firmware loaded but I have had no joy.

The ENC28 network lights do not even light up. I have the module plugged into socket 6 on my Cerberus and I have tried the following

  1. Powered USB
  2. External Power from Wall Wart
  3. PC USB
  4. Changed Gadgeteer Cable to one that is known to be working with another module

I can set the network config in MFDeploy with no problem, but any attempt to work with the ENC28 fails. For example sending a UDP message fails with an Exception, all the exception tells me is that it is a SocketException with no other detail at all other than an HResult of 0xFF000000.

And finally, the device capabilities of the cerb.

HalSystemInfo.halVendorInfo: Copyright Oberon microsystems, Inc.
HalSystemInfo.oemCode: 255
HalSystemInfo.modelCode: 0
HalSystemInfo.skuCode: 65535
ClrInfo.clrVendorInfo: Copyright Oberon microsystems, Inc.
SolutionReleaseInfo.solutionVendorInfo: Copyright © GHI Electronics, LLC
SoftwareVersion.BuildDate: Oct 23 2012
SoftwareVersion.CompilerVersion: 410462
FloatingPoint: True
SourceLevelDebugging: True
ThreadCreateEx: True
LCD.Width: 0
LCD.Height: 0
LCD.BitsPerPixel: 0
AppDomains: True
ExceptionFilters: True
IncrementalDeployment: True
SoftReboot: True
Profiling: False
ProfilingAllocations: False
ProfilingCalls: False
IsUnknown: False

Can you ICMP ping your device?

@ Gus - No, the device does not respond to ICMP pings.

To be clear, you have set static IP through MFDeploy and other network settings. Then you try to ping the device but nothing happens.

That is correct, I used MFDeploy to set a static IP. I also tried setting the IP address in code, and using DHCP. But currently it is set to a static IP from MFDeploy.

The module it self seems dead, the network indicator lights are not even coming on when the cable is plugged in. The same cable etc. works with the J11D on the Spider.

We can change it no problem, but we should double check on our end as well.

Can you take a closer look at solder connections, especially the through hole connector?

@ Gus - Thank you for the offer, but since I order off mouser I would not expect that you would replace it. The best I am hoping for is that I was missing something obvious. I have checked the module under a magnifying glass and could not see anything obvious wrong.

you’re still running, not the latest beta/RC, and networking was one of the things that changed.
Edit: maybe that is the latest after all; I’m no longer sure :slight_smile:

@ Brett - If I am not mistaken, is for the Premium firmware. The OSHW firmware versions are 4.2.3.x

Here is what I have
Spider v4.2.5.0
FEZ Hydra v4.2.3.1
FEZ Cerberus v4.2.3.2

All from the 24/10/2012 Release

yup, glad I edited my post…