No Luck. The 2 DnsAddresses returned are the ones defined in the router ( and if I set the first of the networkInterfaceSetting.DnsAddresses to my Gateway IP-Address (for me: I still get the same error. Note that the device name are not listed in the router (but found via the winform app)

Strange, that you cannot find the device name of your PC in the list of the connected devices in your router. What kind of router is it? Do you have an Enc28 or a WiFi 7 Click module to test if they show the same behavior? Perhaps one of the other insiders can test if they see the same issue with built-in Ethernet (unfortunately my built-in Ethernet has died)

The router is a technicolor. Got it from the provider. Doesn’t seems to be used a lot
I did the tests with the Eth Click. Apparently, I can’t connect with the latest firmware (even it it worked once)
I tried yesterday with a No-IP account. (DDNS)
I can now get it now via IPHostEntry host = Dns.GetHostEntry(“myid.ddns.net”)

since it worked once, have you tried to reboot the router?

yes, several times. Then switch back to first TinyClr preview -> same
Then realize that I made a mistake : linkReady was set to true instead of linkReady = address[0] != 0.
After changing the line , everything was fine
Then upgrage to preview2 -> still ok
Then upgrade to preview 3 -> still ok
The day after, with no code changes (I checked twice), no go every time I try
But always good with ETH Click
DHCP set true or false do not change anything :frowning: