Device not found or cannot be opened

HI all,
i’ve just bought a Fez Spider Kit. Yesterday i’ve received it, unpacked… installed all the things necessary on a brand new Win7 x64 Ultimate PC (c# Vs 2010, lybraries, SDK drivers and so on).
I’ve updated the Spider Firmware sucessfully and now the version installed is

But here comes the problem. I was looking throgh the tutorial trying to making a led blinking. VS compile the solutions without any error, but when it tries to deploy the application i receive this error message:

Error 1 Device not found or cannot be opened - USB:Gadgeteer

I’ve looked in VS and it seems that the class is correctly loaded. The deploy is set to be executed through USB.

I can connect with the device with MFDeploy.exe and this is the result:

Pinging… TinyCLR
HalSystemInfo.halVersion: 4.1.2821.0
HalSystemInfo.halVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
HalSystemInfo.oemCode: 255
HalSystemInfo.modelCode: 0
HalSystemInfo.skuCode: 65535
ClrInfo.clrVersion: 4.1.2821.0
ClrInfo.clrVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.targetFrameworkVersion: 4.1.2821.0
SolutionReleaseInfo.solutionVendorInfo: GHI Electronics, LLC
SoftwareVersion.BuildDate: Dec 22 2011
SoftwareVersion.CompilerVersion: 410561
FloatingPoint: True
SourceLevelDebugging: True
ThreadCreateEx: True
LCD.Width: 320
LCD.Height: 240
LCD.BitsPerPixel: 16
AppDomains: True
ExceptionFilters: True
IncrementalDeployment: True
SoftReboot: True
Profiling: False
ProfilingAllocations: False
ProfilingCalls: False
IsUnknown: False

Even changing name, in NEOBE i’ve got the same error:
Error 1 Device not found or cannot be opened - USB:NEOBE

I’ve installed the develop enviroment on a Netbook… and got same error.

Any hint?

I suspect it is power issue. Try powered hub or power pack.

i’m very busy trying to use this new “toys”… :smiley:
So… i’ve tried to connect to a 12V 1A power supply and tried again to deploy… with no success. :frowning:

Make a new console netmf application. Do not add any changes and deploy to your device. Does it work?

Created a new .NET MF ConsoleApplication…
Changed the target from Emulator to USB… VS choosed correctly EMX_NEOBE.
Tried to go in DEBUG but still got same error.

------ Build started: Project: MFConsoleApplication1, Configuration: Debug Any CPU ------
MFConsoleApplication1 -> C:\Users\warfox\AppData\Local\Temporary Projects\MFConsoleApplication1\bin\Debug\MFConsoleApplication1.exe
------ Deploy started: Project: MFConsoleApplication1, Configuration: Debug Any CPU ------
------ Deploy started: Project: MFConsoleApplication1, Configuration: Debug Any CPU ------
Device not found or cannot be opened - USB:NEOBE========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

I’m usig Win7 ultimate ITA on an Atom 330 PC. VS 2010 Express licenced.

This is strange! What do you see on the display?

Debug: USB1
LCD: 320x240
MAC: 00.1A.F1.00.42.0D
Managed Heap size: 13041664
Custom heap size: 1048576

Waiting for debug commans…

Have you ever set DHCP option?
Have you tried on more than one PC?
Have you restarted the PC?

I’ve tried with this one and with a Netbook… I can try with a MAC with VBox emulation. PC has been reboot more than one time.
With DHCP you mean networking? Actually Spider is not connected to the network; anyway all net is DHCP if you think it worth i’ll try a TCP/IP deploy.

I’m available to a Teamviewer session if could help.

I do not know then!

So this is what you have?:

  1. spider connected to a PC using USB and DP module
  2. power pack is added to the DP module, 12V
  3. mfdeploy can ping the device and show configuration, even change USB name then close mfdeploy
  4. open VS2010 express and make new console netmf application
  5. hit F5 and get deploying error
  6. have tried this on 2 PCs

You got it. Anyway… i’ve installed the Env on OSX and it WORKED!
I’ll try to re-install th env on the Atom PC and see what’s happen.

I had this issue, and I realised that I hadn’t changed the switches back after updating the motherboard on the initial installation.

Just in case anyone else is having it…