Deployment difficulties

I upgraded to the 4.2 version and ran into the issue with the EMX drivers not finding the right folder. After a bit of searching the forums I found the solution and was able to get the driver situation squared away. Everything seemed to be squared away until I went to deploy the code. After a number of tries I went digging in the device manager and found that the debugger was listed under USB devices rather than COM ports. Is this correct or did something get messed up in the upgrade? Any thoughts on why I am having trouble with this? I have lots of new modules and want to get coding with them.

Welcome to the forum!

It should be under USB by default. What board are you using?

I am using a Spider board.

Good. Yes, it is supposed to be under USB.
Select USB in Visual Studio project properties and it should find the board.

Prior to upgrading the board was listed under there. Now the only thing listed when I click the drop down is EMX-EMX.

You have probably saw it there after you have changed the switches just before doing the upgrade.

Potentially, I should have paid more attention to the settings prior to upgrading for error tracking. I just need to find out how to get things back to working. When I hit debug in visual studio it acts like it is doing something but basically times out and says there is an error communicating with the device.

I would try to repeat upgrade process.

Doesn’t “EMX-EMX” show that the device IS found?

It does, but he can’t run/debug.

Can you tell us what device capabilities shows from mfdeploy? That’ll help confirm the firmware loaded successfully. And are you having trouble deploying a new vanilla project (create new project, don’t change anything except the target to be the USB EMX device, and deploy) even though you can use mfdeploy to ping the tinyclr?

went through an uninstalled everything to get back to a clean slate. From there went back through the installation process, upgrading everything before next steps and it seems to be working fine now. Able to get talk to the modules I have tried so far, except the WiFi which I believe there is a know issue with, correct? Also, tried to check out the Glide and cant find the code anywhere, looked on the forum but the links all seem to be broken.

Here is the link to Glide web site

Yes I am familiar with the website but the link to the codeplex has no downloads

you need the source code, it’s just not bundled as a release (which would then appear in the downloads)

Ok, you guys must forgive me, I didn’t see the very obvious “download” on the code page. I think I should be good form here. thanks

Got the code but having some other issues, I will create another thread for them and let his one pass into the archives