Main Site Documentation

Deploying TinyBooter to FEZ Hydra with SAM-BA


#1

Hi,

Im using the Beginners guide to Porting NETMF guide in attempt to build the NETMF from source and deploy it onto my Fez Hydra board. But Im having some issues. Ive successfully built tinyCLR and tinyBooter, but Im not able to deploy my own tinyBooter to the board.
Ive erased the flash and installed the usb-serial drivers, so I can see the board on COM3 or COM4 in device manager. When I open the SAM-BA program included with the SDK (sam-ba_cdc.exe, version 2.10), I can select the serial connection to the board, and I select at91sam9rl64-ek as the board type, then click OK. Every time I do this, the application quits with an error message (http://i.imgur.com/1kXi1xx.png).
Ive tried downloading a newer version of SAM-BA (v. 2.12) from atmels website to see if i could install tinybooter with that. When I run that version and click connect, the window disappears and SAM-BA hangs indefinitely.

Interestingly, the sam-ba_cdc program does work when I use the UpdateFEZHydra.bat script. I guess, in theory, I could use that script to deploy my compiled firmware, but I dont know where the FEZ_Hydra_Tinybooter.bin and GHI_OSHW_BOOTSTRAP.bin would come from after I build the TinyBooter project.

Im wondering what could be causing my inability to connect to my board in SAM-BA.


#2

Welcome to the forum.

Can I ask, is there some reason you’re trying to build a custom firmware? The GHI provided open-source one is ready to go if you just download the SDK…


#3

I’m working on a custom application that would require me to use my own custom bootloader build. I’m able to do what you mentioned (downloading the GHI firmware), but I’m not able to connect to my board in SAM-BA to deploy my own.


#4

OK, understood. Just wanted to check you weren’t unnecessarily complicating things.

Only reference I have for you is http://www.ghielectronics.com/docs/125/firmware-update-fez-hydra

But looks like you’ve pretty much done the right things there. I think though that you could step through this and make sure that the standard firmware update process worked as expected with the standard firmware.

As for where the BIN files would be once you’ve compiled things… that’s going to be a very important point if you need to deploy a custom one - dig dig and dig some more until you find them :slight_smile:


#5

I’ve never seen that error before, but from what you’ve said, I guess my advice would be to change the BAT file to use your custom-built TinyBooter instead of FEZ_Hydra_TinyBooter. Or maybe try using the BIN file instead of the HEX file that the build tree spits out.

I have no idea what GHI_OSHW_bootstrap is (maybe something to do with LCD config?), but since you’ve built the same code as GHI, you could try loading the GHI bootstrap file, too? Or just omit it?

Having said all that, I’d recommend just using JTAG, which is broken out on socket 1. Even if you are able to deploy a binary image using SAM-BA, it’s really only useful for loading production firmware or doing in-field updates – you’d never actually want to do any development without access to a JTAG interface. Otherwise, you won’t be able to watch variables, step through code, set breakpoints, etc.


#6

About the error of Samba I got same error deploy the Tinybooter. I got that it need some env variable setting for something relative to the Windows display. I red that on the Atmel forum months ago something about, but I haven’t the link anymore. It uses TCL so probably need some setting for Windows screen
You could try to run it in WinXP mode with 256color screen.