Main Site Documentation

Deploy fails on 4.1 SDK


#1

If I run from Visual studio it works.

Then I use MF depoy to get the hex file.

But if I deploy the hex file on to my boad.

It fails telling sig failed etc…

Would you please try at your end


#2

If we restart this is what tera-term shows

Attributes = 0 bytes ( 0 elements)
TypeSpec = 0 bytes ( 0 elements)
Resources = 0 bytes ( 0 elements)
Resources Files = 0 bytes ( 0 elements)
Resources Data = 0 bytes
Strings = 496 bytes
Signatures = 181 bytes
ByteCode = 314 bytes

Resolving.
Link failure: some assembly references cannot be resolved!!

Assembly: Microsoft.SPOT.IO (4.1.2821.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.1.2821.0)
Assembly: GHIElectronics.NETMF.SQLite (4.1.3.0) needs assembly ‘System.IO’ (4.1.2821.0)
Assembly: GHIElectronics.NETMF.Net (4.1.3.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.1.2821.0)
Assembly: GHIElectronics.NETMF.Net (4.1.3.0) needs assembly ‘Microsoft.SPOT.Hardware.SerialPort’ (4.1.2821.0)
Assembly: GHIElectronics.NETMF.Net (4.1.3.0) needs assembly ‘GHIElectronics.NETMF.System’ (4.1.3.0)
Assembly: GHIElectronics.NETMF.Net (4.1.3.0) needs assembly ‘Microsoft.SPOT.Net’ (4.1.2821.0)
Assembly: GHIElectronics.NETMF.Native (4.1.3.0) needs assembly ‘GHIElectronics.NETMF.System’ (4.1.3.0)
Assembly: Microsoft.SPOT.Hardware.SerialPort (4.1.2821.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.1.2821.0)
Assembly: GHIElectronics.NETMF.W5100 (4.1.3.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.1.2821.0)
Assembly: System.IO (4.1.2821.0) needs assembly ‘Microsoft.SPOT.IO’ (4.1.2821.0)
Assembly: GHIElectronics.NETMF.System (4.1.3.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.1.2821.0)
Error: a3000000


#3

Update both, firmware and GHI libs. If not sure, make new project


#4

Did that, but did not help.

But see…It works when I run from Visual studio.
But failed when I extract the hex file and deploy it on the same board.

The hex file extracted from 4.0 is 675K.
But the hex file from 4.1 is only 130K. I guess it did not extract the full image


#5

You can’t extract a file from 4.0 and load it on 4.1!

Start fresh, use 4.1 only…make new project…extract image…try to deploy on same system…it will work just fine :slight_smile:

You are maxing things back and forth on versions.


#6

Looks like I confused you.

I have 2 PCs one running 4.0 and another runnig 4.1.
Because I am not sure how good the 4.1 is. So do not want to mess up my working setup.

So on the 4.0 PC I extract the hex file it is 675K.

On the4.1 PC the hex file extracted is 130K.
So I am telling that is the reason it is telling. missing libraries.

On ChipX I am not even able to extract the hex file to deploy it on another board. It is stuck


#7

Then where did the link failure come from?
Please start fresh and use 4.1 only. We cannot help you if switch between versions and report old issues…
make a new project and deploy, does it work?
add several assemblies, does it work?
…etc
Please put complete debug output here if you have a problem.

If you are trying to port old code and trying different versions, it is easy to mix things up.


#8

I have no answers (since I don’t know what you’re talking about) but perhaps I can help interpret what is being said.

You compile a project under 4.0 and extract a “complete” hex file and that’s a certain size.

Under 4.1 and VS2010, an equivalent project, with correct references etc, you extract a hex file. It seems that process you’re suing should be different since the size of that hex file is much smaller, and you get those errors.

You need to know how to extract a “full” hex file that contains all the dependencies needed to properly deploy using MFDeploy.

(hope that’s better and easier to understand)


#9

Brett…That is exatly what I am doing.

And I figured out my issue.

I had GHIElectronics.NETMF.Hardware.ChipX included in my project and that messed it up.
I removed it and now the deploy works as I expect it.

Looks like 4.1 hex is much smaller than 4.0. But that was not my issue.

Any way now it is fixed.

I see one issue though. But not a show-shopper. But enough to get my produciton folks worried.
The very first time I deploy it on a new board MFDeploy complains about signature verification error. But it works
The second time on the Deploy does not complain about signature error

This only happens on 4.1. Do you know how to create a sig file


#10

You shouldn’t have any signature errors! Maybe we are mixing thing again like last error?