Main Site Documentation

Debug over ethernet


#1

i have been trying to get my Cobra to debug via ethernet, but I can’t seem to get it to work. The Cobra is turned on and connect (with a DHCP lease), and although it is listed in MFDeploy in the TCP/IP drop box, I cannot connect to it. I get…

[quote]Failure - Device 192.168.15.8 - (00-1a-f1-00-42-0d) is invalid or not responding
[/quote]

Any ideas?


#2

Gus said in another post it needs a static IP (ie: not DHCP). Have you tried that?


#3

Yes, you will need to use a static IP address for debugging over ethernet, have you tried this?


#4

What’s the point with static vs dynamic address here ?
Unless MFDeploy is checking that particular point and refuses to work with a leased address, there’s no difference between static/dynamic address ?!

I would understand that MFDeploy could not find the board with a dynamic address, but it’s not the case here.

Is there something I’m missing ?


#5

just my troughs about this:

When you use a DHCP IP address the IP does not need to be there when th cobra is restarted, First it needs to talk to the DHCP server of he still can use that IP address etc.
In the maintime MFDeploy try’s to connect to the cobra and fails.

This is totally hypothetical.


#6

You may be right but Chris said that MFDeploy did find the board, so…

Also, DHCP servers are smart enough to give the same address back to the same device in many cases (without assigning MAC & IP).

I would be curious to see the answer to this, anyway.


#7

The board gets reseted when you deploy and DHCP is not active on power up, we disabled it to speed up powering up.

So, if you want to debug over Ethernet then you must use static IP.


#8

For all of the DHCP questions, the board gets a DHCP lease after bootup, in code. Until it gets to that point, however, it does have a properly configured static address.


#9

I have my answer :wink:

Chris doesn’t ???


#10

Bec, look in the EMX manual, it explains it there.


#11

Q.E.D… :smiley:

Thx, Chris.