Main Site Documentation

Dead Panda II - No led - Hot


#1

Hi guys,
I’ve been working on a project with my new Panda II and so far it’s been great. However, I think I may have fried it today.

Long story short I hooked up the com 1 rx pin to an open collector connection on a 12v car ecu. I also had a 6.8k resistor between the rx pin and +5v. It’s worked previously so I don’t know if it’s related or if I managed to short something while hooking it up.

Anyway, after making the connection my P2 died. Here are the symptoms. Any idea if it’s something I can repair? The following happens regardless of USB power or external power. I have no shield on it or anything.

  • 5v pin reads 4.8v
  • 3v pin reads .5v
  • LED never lights up
  • PC no longer recognizes the P2 as being connected
  • Both voltage regulators get too hot to touch (especially the 3.3V)

Here’s what I’ve tried so far.

  • Removed both voltage regulators to test them (both output correct voltage when removed from the P2)
  • Diodes D2,D3,and D4 have same voltage on both sides
  • With 5v reg installed only it outputs right at 5v and isnt hot
  • As soon as I put the 3.3v reg back on things get hot and the voltages drop

To me, It seems like something is causing major load on the 3.3v side of things. I’m just hoping it’s not the mcu.

Thanks for your help.


#2

Theres a good chance your worst nightmare is true; sounds pretty much like the mcu to me. The fact that the 3v3 reg is fine when off the board is the most telling to me. Order a new USBizi100 from GHI and solder it in?