Cold deployment of .hex files

I can use MFDeploy to capture a .hex image of my application, and I can use the IFU mechanisms to do a self-update, presuming I am running an app that knows how to discover the file, load it and trigger the deployment, but I can’t seem to get MFDeploy or FezConfig to deploy my application .hex file to a G400 that is up to date, but not running an app.

For instance, if you have a box of G400’s, how would you deploy your app to all of them without VS?

Thanks in advance!

EDIT: I should have explained the issue with MFDeploy… It does an erase cycle, reboots the board, and then times out before the G400 reconnects. Because of this, it never manages to do the actual deployment phase. Same result with either 4.3 or 4.4 MFDeploy. I am running with the updated bootloader.

USB cable, lacky bands and a bottle of Tequila

I have two out of three of those, plus limes and salt. That should do it.

I am sure Bill’s answer is spot on, but if anyone else want’s to chime in, that’d be swell.

I used FEZConfig to deploy hex files to a G120 (custom board) just fine several times (FW 4.3.7)
If you create the HEX File wit MFDeplay with a sig file, you can even put These two files into the same Folder as the Firmware HEX files and FEZConfig will load it onto the board right with the Firmware in one step.

I do a teraterm bootloader update, cold boot and then MFdeploy with both netmf and application hex files.

@ Reinhard - hmmm - I was missing the .sig files. That’s certainly what was breaking my FezConfig effort
@ David - that’s what I tried at first, and it works on other boards, but on the G400 the reset sequence seems to be too long and MFDeploy fails the upload

Thanks to you both for the feedback.

EDIT: FezConfig worked great once I created the .sig file. I had avoided this before because I just presumed that the sig would be verified and rejected by the board, but nope - it happily takes whatever I give it.

1 Like

@ mcalsyn - When deploying only your app.hex file with FezConfig on the Deployment page, the sig file should not be needed.

1 Like

@ Reinhard Ostermeier - I see that now. I guess I just have to use the tools the way there were intended. :-/
Thanks much!