Main Site Documentation

Cobra II + CP7 running Glide


#1

I have read on forum that there had been a problem with running Glide on Cobra II with CP7, I need to know if that isue is fixed with the latest firmware?

In version info stands: Improved Display CP7 module driver.


#2

I have CobraII, I have CP7, and running Glide just right now on my desk. Appears to be working totally fine…

(but I’m not a Gadgeteerer)


#3

Thanks Simon.
So now I have got my CP7.
But getting I2c error do you have isues with that?
tried simple test from this thread http://www.ghielectronics.com/community/forum/topic?id=11372&page=2

I’m using mainboard Cobra II with firmware 4.2.10


#4

Interesting. I’ve tried running code from that thread, and I get the same I2C transaction errors. Even without Glide in my project. So I guess something is wrong with Gadgeteer, as I run exactly the same hardware with Glide, but on plain old .NET, not Gadgeteer. I even use pretty much the same CP7 code, so the problem is probably in the Gadgeteer core itself. Perhaps some incorrect I2C bus configuration, or something…


#5

Aha, things just got more complicated. I reflashed CobraII to my (working) code, and guess what? I2C transaction errors! Then I powered off the whole thing, turned on again, and now it works!

So it seems Gadgeteer code crashes the display controller somehow.


#6

I got it working.
Removed GlideTouch.Initialize(); Thing if also was communicate to the I2C bus.
You’re right if there has been an error with I2C the board needs to be on powered.
Thanks for feedback.