Main Site Documentation

Client DP USB died?


#1

I have a client DP that happily powers a gadgeteer board but the USB side doens’t work.
Its been fine all day but i just went off for a few mins thinking time and came back, to find i couldt deploy any more. De/Re connected and no bongs. Swapped out the dp for another one and bingo. Back to the original power but no USB.
Anyone seen this before? Its from a Spider Kit i ordered in Jan so i guess i may have to contact Mouser


#2

@ HughB

When you swapped out the other DP power supply, did you also change the Gadgeteer cables? Perhaps the Gadgeteer cable went bad. Try a different cable and even a different USB cable to see if that works.


#3

I used the same cable as that was my first thought but the cable is fine. Tried different cables etc. Depending on how much the shipping will be (and if mouser will rma just this part of the spider kit) it may be easier just to buy a new DP module.


#4

Looking at the schematic for this, it’s just a straight pin for pin connection.

Are you able to test for continuity?

I also noticed that there is no transient protection on the USB lines? I checked the schematic for the Hydra I have and it has none either.


#5

@ Dave McLaughlin - That module is now working again. I dont know what happened to it. After swapping it out for other ones to test, which proved that module wasnt working i left it for about an hour and tried again. Still no joy so i gave up on it. The following day just before I ordered a replacement I tried again and whadya know, it worked and has continued to work.
The only thing I can come up with is maybe some sort of thermal cutoff had kicked in. I had a few modules attached to the cerb but nothing that’s on the known power hungry list.
Im going to keep an eye on it and see if i can replicate it.