Main Site Documentation

Chipworkx not recognized after erasing firmware


#1

I erased two of my chipworkx modules to downgrade the firmware. They where version 4.1.7.0.
After erasing the flash, the screen went white and thats it. Windows does not detect anything when I plug in the USB cable.
Also the screen remains white. I tried the emergency bootstrap procedure with the jumper, but nothing seems to be happening.

I have upgraded several modules in the (recent) past, but never with this firmware. I did not have any problems then, so I can’t understand why its not working now.

Any suggestions?

I also noticed that the Chipworkx Update Applications link is dead. Is this somehow related?


#2

There is little jumper on chipworkX module. Remove the jumper and power the system.

Windows will detect the device and then put jumper back and proceed.


#3

Gus,

Please read my post carefully.

It’s still like this. The device is not beeing recognized by windows and also the display remains white, no matter what I try.


#4

Reset PC maybe?


#5

Yeah, I tried that as well. Also on a diffrent PC. Two modules remain dead.

Should I order some flowers for them? :wink:


#6

Sorry to hear about that and I am not sure how to debug this further.

One last thing. toggle the WAKUP pin, maybe the processor went to sleep for some reason!
Use a piece of wire then touch it to 3.3V and to GND.


#7

I’m really puzzled right now.

I just erased a third chipworkx module and again it did not do anything anymore after the reboot.
I removed the jumper, powered on, replaced the jumper, inserted the USB cable and presto: There it was again.

I downloaded TinyBooter and used MFDeploy to install latest firmware. So, this one workes, however I did need to use the Jumper procedure.

I also tried both of the other ones that I have bricked before, and to my supprise one of them is back to live. The other one is still dead though.

The cpu sleep pin did not do the trick for me. Still have one bricked device.


#8

What you could still try is connect to COM1 (via uart2usb or uart2rs232 chip) and check what it says.

If it simply says RomBOOT and nothing else it’s trying to boot something. If it says RomBOOT and then a > in the next line it should be in SAM-BA mode. In that case check your drivers or use usbview to see if something is connected.
You should always go into SAM-BA mode when the jumper is removed and no SD-card is in the device (and nothing else is connected but the adapter on com1). If that’s not the case your module is probably broken. You could still check with JTAG if you have an adapter…

P.S. Below a picture of CWX in SAM-BA mode.