Change the rate of the internal clock

Lots of classes have changed to provide more readable names. So RTC becomes RealTimeCLock and RLP becomes RuntimeLoadableProcedure.

RealTimeClock is like this.

using GHI.Processor;

DateTime DT = RealTimeClock.GetDateTime();

ho ok ty ! (this doc is outdated for the4.3 )

so for my history of Pin. it’s the same case ? Just find the new name?

Yes, I think those docs will be updated when the Beta ends. Probably fairly soon.

For this pins I would do the following on the G120


I think you need something like

GHI.Pins.Generic.GetPin(“A”,13) for pin PA13

I have not tested this.

t test GHI.Pins.Generic.GetPin and it’s work
thank you !!!

i can return to use rlp where i’ve a system.exeption when i use this code

 elf_file = Resources.GetBytes(Resources.BinaryResources.RLP_test);

            functionName = new RuntimeLoadableProcedures.NativeFunction("FillByteArray_c");

            elf_file = null;

in this line

Sounds like a malformed elf_file.

i have take this
I have not changed files.
delete Output folder contents, do make and added to the resources of my project two files output folder.
so for me it’s good

Your RLP.h is missing this :-

 #define RLP_ADDRESS		 0x2001A000 
 #define RLP_SIZE		0x2FFC

i delete old file in my project, change RLP.h, do make, add new file in my project, but same error

Hmmmm, I think im at the end of the help I can give without digging out my Cerb and giving it a go. I don’t really have time at the moment.

Maybe someone from GHI knows more when it’s morning in the US.

No problem, thank you so much for your answers !

@ francois910 - The RLP files you got from that link might not work anymore. I would download and run the make command in the Cerb Family folder. The output file it generates has worked in my test, see if it works for you.

Yes ;D it works
Thank you !

1 Like