Main Site Documentation

Cerbot Controller - missing in newest Discontinued SDK files?


#1

Sorry if this is in wrong place, or is unclear…I am a novice at Gadgeteer programming.

I just updated my SDK to the new 2014 4.3 R2 release. I quickly noticed there was no Cerbot entry in the Toolbox for the Designer window.

I then installed the ‘GHI Discontinued Gadgeteer Products SDK’ file. Cerbot is back, but there is no Cerbot Controller object in the Toolbox.

How do I program actions like using motors, LEDs and piezo on the Cerbot now? I can always roll back to using older SDKs, if this is just not going to work as expected.

To be clear, I had been learning to program the Cerbot using code found under GTM.GHIElectronics.CerbotController previously and all functions worked as expected.

Sorry if I am missing something totally glaring here. Thanks in advance for your help!


#2

@ Beedlebub - The CerborController code was actually merged into the mainboard itself. In a Gadgeteer project, you can find all of the methods on the Mainboard object. Something like:


void ProgramStarted()
{
    Mainboard.TurnOnLed(1);
}


#3

@ John - Thanks so much! Worked like a charm! I’ve already updated all my Cerbot code from prior SDK to run on new release. All working great so far. Thanks again!