Main Site Documentation

Cerberus with ENC28 powered by USBClientDP Started Blinking Power LED


#1

I have four systems; each system is configured with a Cerberus v1.1, ENC28 v1.1 and a USBClientDP v1.3 module. The systems have been connected to a network and running for a month and all of a sudden the USBClientDP modules LED started blinking on two of the systems. After narrowing it down I found that if I unplug the ENC28 the USBClientDP LED will stop blinking indicating that it isn’t trying to source too much current.

I have not had power problems with these units before and all of a sudden they fail. I’ve even removed the network cable from the ENC28 and it still fails. I’ve tried two different power supplies and get the same results. The spec’s on the two supplies are: 12v 1amp and 15v 4 amp.

If I unplug the two systems, let them cool off, and then power them up again they will run for about 5 minutes and start failing.

What is going on here? It looks like the ENC28’s have failed, but I have no way of knowing other than when unplugged the system starts working again.


#2

Can you deploy a simple program to the board that initializes the network but does not use it and see if they still fail? If so, can you try the same on another mainboard like the Spider?


#3

@ John - I’ve modified the code to just initialize the ENC28 on the Cerberus and the system still exhibits the same problem. I did notice that even when cooled down and plugging in only the USB cable to program the Cerberus that the USBClientDP started blinking again. I’m using a USB cable that has an extra USB connector for power only so I’m supplying 1amp to the system. I don’t have a Spider at this time to test if it behaves the same way. I did try a Hydra unit that I have. I don’t have any code loaded on it to init the ENC28, but after leaving it on the 5v USB cable for a few minutes the DP started blinking again.


#4

And do the other two USP DP’s work fine with all the boards?


#5

So you have two “working” and two “failed” systems. You can move the ENC28’s between systems, between power sources, between ClientDP modules, and between Ethernet cables, to confirm if it’s the DP module or the ENC28’s or something else…


#6

@ John - I’d rather not test it just in case the DP or the ENC28 is bad! But, what I did do is use a Extender module and cut the 3.3v trace between the two sockets so I could measure the current draw of the system behind the DP instead of being in front of it. Here are the measurements of the bad system:

Cerberus only: 70ma
Cerberus + ENC28:197ma

Now on one of the good systems I took the same measurements:

Cerberus only: 69ma
Cerberus + ENC28:193ma

So, with this in mind I decided to taking a reading of the system that fails when everything is a room temperature and when the DP starts to blink. It took one hour for the unit to fail:

Cerberus + ENC28 cold DP NOT blinking:197ma - 1:34pm
Cerberus + ENC28 hot DP blinking: 1200ma - 2:39pm

Testing with a working system and used the already hot DP from the first system failing, waited for almost an hour and recorded the results:

Cerberus + ENC28 hot DP NOT blinking:197ma - 2:42pm
Cerberus + ENC28 hot DP NOT blinking:197ma - 3:33pm

So, my initial reaction is that the ENC28’s have gone bad. And the follow up question of why?


#7

Should I request and RMA so I can get these exchanged and someone at GHI can inspect them to determine the problem?


#8

@ csailor - It would be best if you can interchange the modules between the ones that appear to work against the ones that appear to fail so we can pinpoint the specific hardware that is failing.

Can you swap the modules that you feel are failing and replace them in the device that you think is working correctly to determine what piece of hardware may be the cause?


#9

@ Aron - I’ve removed the ENC28’s from both of the systems that are failing and tried them in a system that is working. Both of the ENC28’s caused the good working systems to fail.

ENC28 #1 sequence from start to fail (less than 20 minutes):

1:41pm - 200ma at powerup
1:51pm - 205ma
1:59pm - 220ma
2:00pm - 1100ma

ENC28 #2 sequence from start to fail (less than 15 minutes):

2:01pm - 201ma at powerup
2:06pm - 206ma
2:07pm - 207ma
2:08pm - 208ma
2:09pm - 209ma
2:10pm - 210ma
2:11pm - 211ma
2:12pm - 212ma
2:13pm - 216ma
2:14pm - 218ma
2:15pm - 224ma
2:15pm - 1156ma

What is interesting is that once the ENC28’s hit the 230+ma range they just start climing rapidly and fail within 10 seconds.

So I believe that this points to two failed ENC28’s… Looks like I’m going to need an RMA.


#10

@ csailor - it would appear that way. Could you try the same experiment but swap the power modules?


#11

@ Aron - I’ve already do that as part of my first testing:

The ENC28’s are bad. But what is crazy is that they will work up until they fail.


#12

@ csailor - I’m not really certain what could be causing that problem with the modules. I suppose an RMA is the only solution at this point.


#13

@ Aron - Well I can send them back and at least someone on your team can test them to see what is happening with them. All I know is that they don’t work and I need them replaced.


#14

@ csailor - If you already submitted for an RMA, we will investigate the hardware as soon as possible after it arrives. 8)