Main Site Documentation

Cerberus Update


#1

Hi together,

i was trying to update my new Cerberusboard, but i doesn’t work correctly.

I have installed “NETMF SDK 4.3 (RTM)” and “NETMF and Gadgeteer Package 2013 R3” on a W7 64 Bit System.

Out of the box i got a TinyCLR with ping and “No response from the device” the update-check with FEZ config. After that i updated the loader with the steps from the site “Loader (TinyBooter) Update FEZ Cerberus”, everthing looks good.
Then i started FEZ Config to update the Firmware. But here i have problem i don’t know what i have to do now. Ping says TinyBooter, Check for Update says 4.2.6.1 on this computer and loader version not available. Firmware Updater says, device is not ready for update (see screenshots).
I also tried it with the MF Deployment Tool, selected the config and firmware file from the “C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Cerb Family\Firmware\Non Ethernet” folder. Here i got also an error with the signature after some time.

I hope for any help! Thanks!
Cheers,
Christian


#2

Hi Christian and welcome to the forum.

Can you tell us what Device Manager shows ? The troubleshooting guide will most likely help here: https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting as it seems to me that the driver hasn’t loaded properly.


#3

Hi Brett,

when i connect the board in boot mode, i see the ST… Driver, when i connect in normal mode, the GHI NETMF Debug Interface driver is loaded.

Cheers,
Christian


#4

and the drivers all appear to be working correctly? No ! exclamation marks?


#5

Hi Brett,

i had a look into the device manager, but there are no exclamation marks on both modes. Everthing looks good.

But now, after the device was lying one day on the table, i get the old messages in FEZ Config again (see screenshots).
Ping results in TinyCLR, not in TinyBooter. Check for updates brings the “No response” message.

I uninstalled and then installed again the 64-bit GHI NETMF USB Drivers, but the same result.

thanks for helping!

Chreers
Christian


#6

So have you tried on different USB ports (USB3 has proven unreliable for some - if you only have USB3 then try a hub). Have you got another Mini USB cable you can try?

I would then go through the manual firmware update process (I know, again) using STDFU Tester, as documented https://www.ghielectronics.com/docs/55/loader-tinybooter-update-fez-cerberus as it seems a fundamental problem on your firmware. Can you confirm what GHI SDK version you have (from Fez Config, it should report 4.2.6.1 if you have the latest, the 2013 R3 release). I would try to only do the STDFU tester and then disconnect and re-connect the device a number of times making sure the device starts and the drivers load correctly each time (check in Device Manager). Only after you’re comfortable that this is reliable should you move to update the firmware with FezConfig.

One final question, were you trying to deploy the Ethernet version of the firmware? If so, did you have the Ethernet module connected correctly? And as a further test, try not to use the Ethernet firmware and see if there’s a difference.


#7

Hi Brett,

sorry for my late response. I hat to finish another project first.

It was the USB-Port. I checked the Notebook and i discover, that i had connected the board on a USB3.0-Port :wall: :wall: :wall:

Now, i use a port from the Dockingstation, and anything is fine. I checked the Firmeware-status on the board with FEZ Config, it’s up to date and “Hello World” is working :slight_smile:

Thanks a lot for your help!!!

Cheers from Germany
Christian