Cerberus update issue

I just received my hydra and Cerberus mainboard,
No issue on hydra,
But not the case with Cerberus, dfu works fine (TinyBooter_4_2_3_3.dfu),
But in MFDeploy, I received Error: Unable to deploy to device message after 10% of Firmware.hex upload.
I use Non-Ethernet version, I have tried by changing cable, usb client, usb port … Same result,
Thanks for your help,

Follow the steps outlined on wiki:

Thanks for this quick reply, but that what I have done … But it always stop at the last step … Uploading *.hex with a error

How are you powering the board? Sp or DP module? Powered USB hub? Sometimes you may need a powered USB hub as the straight current from the PC may be lacking. If you have the DP module, you can plug in an external power supply to maintain good current flow.

Did you remove BOOT jumper after loading TinyBooter?

Thanks Aron & Architect,

Aron : I use Sp, I don’t have a DP Module. I have tried with USB on my laptop and also with the hub on his docking station. Is the cerberus more sensitive than hydra in this case ?

Architect : Yes, I use a simple cable to put cerberus in this mode. With this cable, I should not able to see Cerberus on MFDeploy

@ pascal06

I don’t think it is more sensitive. Do you know what debug driver you are using? Is it WinUSB or Original GHI debugger? Are you using a USB 3 port? Many different NetMF devices have been reported as having issues on USB 3 ports.

Original GHI, 1/13/2010,,
I have two USB 3 on my laptop, but the hub is USB 2,
I have also a USB 2 on laptop, I will try this one

Same result,
It always at the same time (10% of the firmware.hex), probably not related to power ?
I will try with another labtop … But it installed with windows 8, any known issue ?

@ pascal06

There have been a few issues seen with Windows 8 and updating, but I am not sure if Cerberus is one of the boards experiencing problems.

No more luck with my other labtop (windows 8),
With my labtop in Windows 7 x64, I’m able to update Hydra, Tahoe II, Netduino and Netduino Plus,
But no luck with Cerberus :frowning:
Do you have another .dfu and .hex file to try (perhaps a previous version) ?

Can you list all of the steps that you have taken to update the firmware?

Sure, after 10 times, I remember :slight_smile:

  • Connect the Cerberus with boot pin connected
  • Remove after boot
  • Start STDFU Tester
  • I see my DFU device
  • Click Protocol
  • Click Create from Map
  • Click Erase
  • Click Go
  • Click Load DFU File
  • Select C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Cerb Family\Firmware\TinyBooter_4_2_3_3.dfu
  • Click Download
  • Click Go
  • Reboot Cerberus (button or unplug/plug)
  • Start MFDeploy (Version 4.2)
  • Select USB
  • I see my Cerberus device (so TinyBooter start correctly)
  • Click Browse
  • Select both *.hex file in C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Cerb Family\Firmware\Non Ethernet
  • Click Deploy
  • Receive a error message at 10%

This is strange indeed… Do you have another USB cable you can try? It seems like MFDeploy is trying to work but something is interrupting its communication.

Yes, it’s strange. When I click to Erase in MFDeploy, sometime it’s work sometime not,
I have tried with 5 differents cables :frowning:
Thanks for your help in any case …

Are you running any Virtual PC software?


Perhaps try to update the Debug driver to the WinUSB driver to see if that will improve the situation. Please note that Hydra cannot use the WinUSB driver; however, If you do not remove the previous driver, Hydra may still recognize that driver and you may be able to operate both devices.

With winUSB, it break later in the process,
MFDeploy freeze at Checking Signature (even if it say Signature PASS) …
Tried 3 times on Windows 8 and 3 times on Windows 7 …
And if I reboot cerberus, it doesn’t boot correctly …

I will purshase another Cerberus to check …