Main Site Documentation

Cerberus does not start in standalone without USB connection


#1

Hello,
I started a quadcopter controller with Cerberus.
Everything is coded and working while connected to the PC for Debug/Release modes. Motors do work.
Module is powered from USB Client DP Module.
I tried to run Cerberus module in the test rig for actual testing
in a balancer to check physically the PID controller in the QUAD, without PC connection.
Just using then a power jack to the USB Client DP Module from a 3s Lipo. Cerberus does not kick in, LED is on!, motors do not run up as when connected to the USB cable. I also noticed it is only functional if the USB driver is loaded in the system. In a different PC where the SDK is not loaded it is not functional either. With the power jack the feed of +3V for the Cerberus and IMU is OK. The 5V feed to the OPTO ESCs are OK (by measuring voltage). The program just does not start without the USB cable.
Anybody has any clue under what conditions one is slaved to the USB connection?
I tried other projects running ofn the power jack without USB. Sort of driving me crazy…Thank you for any idea.
LC.


#2

@ LuisCabrera - Are you using 4.3 beta ?
4.3 beta3 has some issue running board with NO active debug in VS. May be same problem apply to your project.


#3

@ LuisCabrera, Deploy a Release build to the device and try again.


#4

Hello, sorry for the delay in answering.
I moved a Do-while loop (the quad control loop) to an external thread allowing the main program thread to finish and allow everything to be set up properly as suggested in the documentation.
It is now functional. To note the “Debug.Print” statements were not really an issue for this.

As a side effect of this, the telemetry uart I used went off when the debugger wouldn´t be attached. In the forum I found an easy fix, introducing a Thread.Sleep sentence right in the beguinning of the program. Both topics seem timing issues of some sort without easy explanation, but I am good now.
Closed. Thank you.
LC.