Main Site Documentation

Cerberus DL40 Programmer not connecting


#1

Hi there fellow Gadgeteers, and especially Taylorza. :slight_smile:

I’m having a bit of trouble using the Cerberus DL40 Programmer (https://www.ghielectronics.com/community/forum/topic?id=10515) to program my DL40. It goes up to where it says “Connecting…”, but then just seems to hang there.

I tried connecting Socket 7 to both sockets (uplink and downlink) on the DL40, but it did not really make a difference. I also tried using two different Cerberus boards and two different DL40’s and two cables. Same thing every time.

This is what I get:

 'Microsoft.SPOT.Debugger.CorDebug.dll' (Managed): Loaded 'C:\data\dev\gadgeteer\samples\CerberusDL40Programmer\CerberusDL40Programmer\bin\Debug\le\CerberusDL40Programmer.exe', Symbols loaded.
The thread '<No Name>' (0x2) has exited with code 0 (0x0).
Press button to start flash
Beginning chip reflash...
Connecting.. 

One thing I have to point out though… since I do not have a button module to put on Socket 6, I simply started the Flash thread from the main loop as shown below. But I do not think that should be a problem.

      
      Debug.Print("Press button to start flash");
      Thread.Sleep(10000);
      flashThread = new Thread(FlashThreadStart);
      flashThread.Start();

I am sure this is just something small, but any advice would be welcome.


#2

BTW button is just a fancy wire. :wink:


#3

Never mind. It was my own stupid mistake. I put the DL40 on Socket 7 instead of Socket 6. It now programmed fine. Thanks again for this great tool Taylorza.

I’ll mark Architecht’s post above as the one that solved the problem, but in reality it was just me not reading the instructions properly.


#4

It’s OK, we’re all waiting to see what comes after “Superhuman” …


#5

@ KiwiSaner - You can always edit your post and change it to a “non-question” type.


#6

It is a pleasure. I am glad you came right.