Cerberus and RTC wakeup

@ geologic -

GHI.Processor.RealTimeClock.SetDateTime(time); // IT HANGS HERE

This line will initialize and start RTC, comment out this line will cause everything relates to RTC work incorrectly.

After removing the 2 caps the board doesn’t hang any more and the RTC wakes up, but always after 60 seconds, no matter the time i set in RealTimeClock.SetAlarm()…

Here is the output of the time:

Time: 09/15/2014 07:30:01
now is            : 09/15/2014 00:00:00-9-09/15/2014 00:00:00 - 7:30:1
Start Hibernate at: 09/15/2014 00:00:00-9-09/15/2014 00:00:00 - 7:32:1
The thread '<No Name>' (0x3) has exited with code 0 (0x0).
Wake up!
now is            : 09/15/2014 00:00:00-9-09/15/2014 00:00:00 - 7:31:2
wake up: 09/15/2014 00:00:00/9/09/15/2014 00:00:00 - 7:31:2
Time: 09/15/2014 07:31:02

Another question… acording to RCT cerberus document, the recomended crystal is one with 6pF capacitance, but according to this post https://www.ghielectronics.com/community/forum/topic?id=6993&page=3#msg154508 the total capacitance of the two caps (14pF) should match the capacitance of the crystal (6pF)… So something is not right here… (in fact, removing the 2 caps and assuming 5pF for the traces, it matches the capacitance of the crystal…)

Any more ideas?

How are you getting that output if the debugger is disconnected?


Connected to VS and sleep mode, just to see the result on the screen.
Disconnected from VS all the modes wake after 1 minute (confirmed with a watch and the led on/off

Remember sleep can be woken by any hardware interrupt. This is not the same as netmf events. These can be caused by framework level functionality.

Also sleep really doesn’t do much to save power anyway. In fact I think the latest firmwares use this sleep mode when idle anyway.

Deep Sleep is what you want. Try it.

I tried this, and it works! Good news! :dance: I only tried one board, as the rest is in operation.

Its a Cerberus HW rev 1.1. which now has Tinybooter, and TinyCLR after awfully many attempts at updating.

1 Like

That’s what i’m trying to achieve, deepsleep / off, but RTC always wake up after 60 seconds, no matter what time i set in RealTimeClock.SetAlarm()…

Anyone has tried deepsleep on cerberus? I’m stucked… RTC always wakes the board after 60 seconds…


@ geologic - I have tried it on the cerbII40 which runs the same firmware.

Also there is this other thread where the OP is doing it.


Are you running Gadgeteer or plain NetMF?

I’m running gadgeteer

Can you try a plain netmf app. Just a wake sleep loop.

See this example.


@ geologic -

just share to you that Low Power mode does only work without VS debugger, not only Cerberus but also all other EMX, G120

Actually without usb all together, not just the debugger! A system in deep sleep is not expected to function, not even usb.

Your code uses interrupt, not RTC. With interrupt i can wake up the board, no problem. With RTC it wakes up, but always after 1 minute…

Yes, i’m aware of that. My board is only connected to USB for power, VS is shut down.
I’m using led on/off and a watch to measure elapsed time between deepsleep/wakeup and always elapsed time is 1 minute…

@ geologic -

I wish we can have that board to check for you!

Can anyone point other crystal compatible with cerberus board?

How is this going? Need a solution!!!

Looks like this is a dead end…
I was planning to use a cerbuino bee to do some remote stuff, but after these problems with cerberus, i gave up on that board…

1 Like

Because we are not able to reproduce here, so I think best solution is, we can test your board if you send it to us.