CerbBee Link failure: some assembly references cannot be resolved!

Just got a few moments to play with my bee, and have gotten stung for the first time :wink:

I removed all the prior NETMF stuff and installed the new 4.2 stuff on this computer. Did the firmware update (non-ethernet) & the TinyCLR update.

Created a simple Gadgeteer project, removed the Net, Net.Security, Touch assembles.

Just had the Bee in the designer and the following code in the ProgramStarted() section:

Mainboard.SetDebugLED(false);
Mainboard.SetDebugLED(true);

And pressed F5 with a breakpoint on the first line. The output contains this:


Found debugger!

Create TS.

 Loading start at 805b870, end 808448c

   Assembly: mscorlib (4.2.0.0)     Assembly: Microsoft.SPOT.Native (4.2.0.0)     Assembly: Microsoft.SPOT.Hardware (4.2.0.0)  
   Assembly: Microsoft.SPOT.Graphics (4.2.0.0)     Assembly: Microsoft.SPOT.TinyCore (4.2.0.0)  
   Assembly: Microsoft.SPOT.Hardware.SerialPort (4.2.0.0)     Assembly: Microsoft.SPOT.IO (4.2.0.0)  
   Assembly: System.IO (4.2.0.0)     Assembly: Microsoft.SPOT.Hardware.OneWire (4.2.0.0)  
   Assembly: Microsoft.SPOT.Hardware.Usb (4.2.0.0)     Assembly: Microsoft.SPOT.Hardware.PWM (4.2.0.1)  
   Assembly: Microsoft.SPOT.Net (4.2.0.0)     Assembly: System (4.2.0.0)  Loading Deployment Assemblies.

Attaching deployed file.

   Assembly: Gadgeteer (2.41.0.0)  Attaching deployed file.
   Assembly: System.Http (4.2.0.0)  Attaching deployed file.
   Assembly: CerbG2 (1.0.0.0)  Attaching deployed file.
   Assembly: Microsoft.SPOT.Net.Security (4.2.0.0)  Attaching deployed file.
   Assembly: GHI.OSHW.Hardware (4.2.3.0)  Attaching deployed file.
   Assembly: System.Net.Security (4.2.0.0)  Attaching deployed file.
   Assembly: GHIElectronics.Gadgeteer.FEZCerbuinoBee (1.0.6.0)  Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: Gadgeteer (2.41.0.0) needs assembly 'mscorlib' (4.1.2821.0)
Assembly: Gadgeteer (2.41.0.0) needs assembly 'Microsoft.SPOT.TinyCore' (4.1.2821.0)
Assembly: Gadgeteer (2.41.0.0) needs assembly 'Microsoft.SPOT.Graphics' (4.1.2821.0)
Assembly: Gadgeteer (2.41.0.0) needs assembly 'Microsoft.SPOT.Native' (4.1.2821.0)
Assembly: Gadgeteer (2.41.0.0) needs assembly 'Microsoft.SPOT.Hardware' (4.1.2821.0)
Assembly: Gadgeteer (2.41.0.0) needs assembly 'Microsoft.SPOT.Net' (4.1.2821.0)
Assembly: Gadgeteer (2.41.0.0) needs assembly 'Microsoft.SPOT.IO' (4.1.2821.0)
Assembly: Gadgeteer (2.41.0.0) needs assembly 'System.IO' (4.1.2821.0)
Assembly: Gadgeteer (2.41.0.0) needs assembly 'Microsoft.SPOT.Hardware.SerialPort' (4.1.2821.0)
Assembly: CerbG2 (1.0.0.0) needs assembly 'Gadgeteer' (2.41.0.0)
Assembly: CerbG2 (1.0.0.0) needs assembly 'GHIElectronics.Gadgeteer.FEZCerbuinoBee' (1.0.6.0)
Assembly: GHIElectronics.Gadgeteer.FEZCerbuinoBee (1.0.6.0) needs assembly 'Gadgeteer' (2.42.0.0)

Error: a3000000

Waiting for debug commands...

The program '[3] Micro Framework application: Managed' has exited with code 0 (0x0).

I removed and re-added the CerbBee reference as it was the only one with “Resolving”; same results.

I’m sure it’s something simple …

Thanks in advance

Did you create a 4.1 or 4.2 project?

@ mhectorgato - I get the same with mine…
Remove gadgeteer reference and re add fixes it for me.

4.2

That did it for me!

Gracias!

@ mhectorgato - champion

@ steven I think 4.2 gadgeteer temple is referencing 4.1 gadgeteer dll

I have exact the same situation :
Updated the 4.2 to the latest version today aftes de-installing all 4.2 software (left 4.1 As Is)
Connected my spider
created a new project : Gadgeteer 4.2 (in c#) (and also tried the same in VB)
just a button and simple command (or even JUST the SPIDER with only the standard Program.cs )
BUILD \ Run gives the same outout as mentioned by mhectorgato.

when i create a new project. with only the Spider Mainboard, The program.cs starts off by not recognising the

using Gadgeteer.Networking

; line
remove that for now…
now i run and i get the same errors that all kinds of references dont match (see mhectorgato.)
Now i checked my Gadgeteer reference => 2.41.0.0 but when i Double click it I see that it refers to the location
C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Mainboards\FEZSpider\NETMF 4.1\GHIElectronics.Gadgeteer.FEZSpider.dll
I remove it and replace it with the dll in the 4.2 directory looks good when i check the location now…

Doing the same for the GHIElectronics.Gadgeteer.FEZSpider dll. (also shows to have the 4.1 directory)
I replace it by the one found in C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Mainboards\FEZSpider\NETMF 4.2\GHIElectronics.Gadgeteer.FEZSpider.dll (double checked this), but when i check the replaced reference, it still shows the 4.1 directory as source ???

I shall remove everything from the PC and install one more time… any ideas >>> ?
thanks
Bert

I checked, and indeed all the GHIElectronics.xxx drives reference the path
C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Modules\RS232\NETMF 4.1\GTM.GHIElectronics.xxxxx.dll

Check project properties window and make sure you have selected target framework version as 4.2.

The 4.2 template adds the 4.1 Gadgeteer dll and not 4.2
Remove the reference to Gadgeteer and re add from the 4.2 directory

I’ve just created a project based on the 4.2 Template and all references are 4.2 not 4.1

OK… All working now…

I completelye deleted all files from the CLProgram… that had anything to do with GHI or Gadgeteer. (Some were left there after i de-installed.

Now i first Rebooted the PC and re-installed all again.

Works like a charm now !!!

Thanks
Bert

@ Architect - One pc is fine but on my main laptop it references the wrong dll.
Uninstall of the previous sdk’s and install of the latest.
Everytime i create a 4.2 Gadgeteer project it references the 4.1 Gadgeteer.dll
I will have a further dig tomorrow as it is a tad irritating.

Weird. :wall:

I had the exact same issue. gadgeteer.dll was the 2.41 version within a 4.2 build. Removing and repointing to the correct file fix it (2.42 version).

I remember I installed step 4, the optional one that installed 4.1. Sooo, I uninstalled everything and did not do step 4. Works fine now.

I’m only guessing that the step 4 did the damage. The machine I installed it on never had 4.1 installed. I guess I really don’t need it. :slight_smile: Not worth the time to make the point.

Speaking of time. Is it just my machine but does it take an inordinate amount of time to load the toolbox content?

@ jwschull - do you by chance have telerik tools installed? If you search on the guid that it stalls on there is a solution on the slow toolbox issue.
I had the same issue which was caused by telerik install.

Justin, No I don’t have telerik tools installed. BUT…Michaels solution nailed it.

Thanks for the advise. Working fine now.

@ jwschull - Yup thats the link i used - makes life so much better after suffering the ssllllllooooowwww startup