Cerb40 on Macbook Pro


Anyone managed to get the Cerb40 working on a macbook pro. I have parallels, win 7 pro and visual studio 2010. I am using NetMF 4.2 (QFE2). I can load TinyBooter using the STDfu Tester no problem. However when I try and deploy TinyCLR using MFDeploy it fails giving me a invalid signature error after about 10mins. Sometimes it just hangs when checking the signature. Furthermore if I ping the device I get a garbled response. It appears there may be an issue with the USB driver running on the VM. I have tried the exact same setup on a Win 7 laptop and it worked fine. If I have to I will use a separate laptop for developing on the Cerb40 but it will be a pain as I use the Macbook for my other development activities (including Xcode, Android and Web based dev). I have done extensive work on the Netduino platform with no problem on the Macbook so it should not be an issue with the VM or installation of VS 2010. This was also on NetMF 4.2.

Any help would be appreciated.


hi Matt, welcome to forum!

the only GHI products that work with VMs are the premium line. that is, products using the EMX and g120 modules, and the USBizi chip.

there are USB issues with VMs and the OSHW devices.

for OSHW devices, the only current solution is bootcamp.

Thanks Mike. Thought that might be the case.


We got us a Mac now so we should be able to do some testing in near future. No promises though.

Welcome to the community.