Main Site Documentation

Cerb40 II - Check your hardware error


#1

I recently bought a Cerb40 II. When I received it, I updated my desktop to the latest Gadgeteer/NETMF 2014 R1 SDK firmware. Then I updated tinybooter, tinyCLR and then the NETMF firmware on the Cerb40 II.

But now when I attempt to deploy a program to the Cerb40 II from VS2010 Express I only get “check you hardware” errors. I have not been able to deploy once. All my other Gadgeteer/SOM stuff works after the update.

My setup is Windows 7 64-bit, VS2010 Express and I am connected to the Cerb40 thru a powered USB hub. I’ve tried connecting directly to my CPU’s usb port with same results

I have searched the forum for the past few days and could only find some similar posts that went unsolved/unanswered.

Thanks in advance.


#2

When you see the error, what devices does device manager see? And did you deploy any code to the device at all?

If you have other mainboards, do they work?

Have you tried connecting to the device with mfdeploy, does that work or fail?

Did you change the connection in the project properties?

Is this a brand new project or an existing one? If not new, create a new one and does the same occur?


#3

When my Cerb gives me hardware error in VS.Net, I use to open up Fez Deploy and hit Erase application. Restart the device and head back to VS… Usually fix the problem at my place.


#4

In device manager I see GHI NETMF Debug Interface.

All my other mainboards work.

I just tried a new VS2010 project and still have the same results. You see the name of the Cerb in the project properties but when you go to deploy its an immediate "check hardware"
error.

I have not been able to successfully deploy once so I am assuming there is no program running on the Cerb.

I tried MFDeploy but nothing shows up under the USB dropdown menu.


#5

Until that works, nothing will connect.

Can you please try erasing fully again with STDFU and reloading the bootloader, then using FezConfig to deploy the framework.


#6

Just finished erasing with STDFU and reloading the bootloaders with FEZConfig.

No luck.

The first two times I tried to deploy VS2010 froze mid deployment. I walked away for about 20 minutes during deployment to see if was just slow.

The third time I got check your hardware again.


#7

Still no luck getting my brand new Cerb40-II to work properly.

I’ve done some experimenting and noticed something. Starting from new VS2010 console application with nothing in it except a debug.print statement I can get VS2010 to deploy and run and application on my Cerb that prints to the debug window.

But if I add a Microsoft.Spot.Hardware reference and try to deploy it never works. Either VS2010 freezes in mid deployment or I get a check your hardware error.

If I then remove the Microsoft.Spot.Hardware reference and deploy, VS2010 freezes again in mid deployment. If I try to deploy a second time with the Microsoft.Spot.Hardware reference removed the deploy is successful.

Any ideas out there? GHI employees?


#8

@ charlieHustle - Are you using a USB 3 port or HUB by chance? If not, during deployment, are any of the other applications running in the background (MFDeploy, FEZConfig or DFU)? We have seen this kind of behavior in both of these cases.