Main Site Documentation

CellularRadio dies after few days


#1

Hi guys,

I’m testing a project started one year ago that uses a CellularRadio connected to a FEZ Cobra 2 Net through the Fez Cobra 2 Extender (socket number 8).
I’m using NETMF 4.2 and I don’t upgraded project to 4.3 because I’m using many modules that are discontinued.

CellularRadio module works perfectly and I can send/receive SMS.
After few days of inactivity (I don’t send SMS to the module and it doesn’t send SMS to me) it stops to receive SMS.
It doesn’t throw exceptions and during “SMS inactivity” I check signal strength every 15 seconds (and it replies that the signal is good). But when I send an SMS it doesn’t receive it.
If I do a power cycle the CellularRadio module starts to work perfectly again (until next few days of inactivity).

I don’t know which other useful information I could give you to understand this strange behavior of CellularRadio module.

I can provide you a sample code but I think it’s unnecessary cause it works without issues if I send an SMS per day to the CellularRadio module… but it’s quite expensive! :stuck_out_tongue:

Maybe the GSM carrier has a timeout/TTL or something related to the protocol?

What do you suggest to check?

thanks a lot
Big


#2

I suggest you upgrade your firmware on the module. I did that a few days ago, and it seems to work more reliably now.

Check this: https://www.ghielectronics.com/community/forum/topic?id=17263


#3

Thank you @ njbuch!

I’ll try to upgrade the SIM900 firmware.
About the FTDI cable, do I need to buy the cable mentioned in the link or could I use a USB-RS232 cable that I already own?

Another question: how can I check the SIM900 firmware version that I have?


#4

DO NOT USE RS232 with it. The interface is actually 2.8V but I think they have a series resistor to limit the current so 3.3V logic should be OK.


#5

I bought the FTDI TTL-232R-3V3-WE cable from Mouser.

I read all the @ njbuch topic but I can’t update the firmware.

I downloaded “SIM900 Series download Tools Customer 1.8” and 1137B13SIM900M64_ST firmware.
Using “SIM900 Series download Tools Customer 1.8” I located the .cla file.

I soldered TX, RX and GND … I connected CellularRadio module to USB Client SP through Extender Module … I connected the “FTDI USB to TTL serial cable” to the PC and, before plugin the USB cable into USB Client SP, I done short circuit between pins 1 and 3 (labeled 3V3 and P3).
After powering the CellularRadio module I removed the short circuit cable between pins 1 and 3.

After that I click on “Start Download” on SIM900 Series download Tools Customer 1.8 and this is the prompt I receive in the lower area:
0’00’000 - Opened COMM port
0’00’000 - Power On/Reset Target

Stop… After that nothing happens…

Where’s my mistake?


#6

likely RX and TX are misconnected. You should connect RX of the device to TX on the FTDI in a “crossed over” manner. Check out UART dyslexia in the comments at SparkFun https://www.sparkfun.com/products/449 I am so paranoid about doing that, that I recently put solder pads onto a Gadgeteer module so I could jumper RX and TX the opposite way around “just in case” :slight_smile:


#7

UART Dyslexia is new to me! ;D
So do you suggest link RX and TX crossed?

In @ njbuch’s topic I read that this was not needed, anyway I’ll try and I’ll let you know!

First step is to communicate via UART for getting the installed firmware version because actually I can’t communicate via UART with the CellularRadio.


#8

I am not sure about the RX/TX crossing, I did not cross them, but you know the cable quality and color indications might not have been true.

I havent been able to communicate directly with the modem attached to my USB port and fire off some AT commands yet, but I am still dreaming about it, for developing more sophisticated controls of the modem. But just attaching it and opening the port never gives a response.

To me, it looks like you might need a reset of the board after opening the com-port?

Furthermore, its not clear from your post if you have sufficient power supply to the module…?
EDIT: An btw, I used the ancient updater I think it was 1.01 and not the new one that you are using…


#9

I suspected that you have used the updater version 1.01, because all the tutorials I found googling were using that version).

I try later!


#10

I have some question:

  1. you wrote that your firmware version (before upgrade I intended) was 1137B10SIM900M64_ST. If you weren’t able to communicate via RS232 how did you get the firmware version? Is written on the SIM900 hardware?

  2. Power supply is by USB port of my PC. May I need to connect a DC power supply (1A or 2A)?

  3. Do I need to upgrade firmware with a SIM card in the sim card placeholder? Or without SIM card?


#11

1: Look at page 56 in the command manual. See image.
2: You should supply more power using the usb-dp module with both G-cable and DC input
3: Dont know, I did with it in the holder.


#12

It worked!! Great scott!! ;D

Some notes of my experience:

  1. I upgraded the cellular radio module using this cable sold by Mouser: 895-TTL-232R-3V3-WE (Mouser code). Using this cable I needed to cross TX and RX cables (Module’s RX linked to cable TX and module’s TX linked to cable RX).

  2. Power supply: make sure to use the USB Client DP with at least 1 Ampere (not only USB cable).

  3. I used an old version of upgrade software V1.01. You can download this zip http://garden.seeedstudio.com/images/8/87/SIM900_firmware_and_tool.zip where you can find the software and a PDF file containing a guide. In this software I set the serial boudrate at 115200.

  4. In many tutorial you can find you must start SIM900 in mode “DOWNLOAD ON” or you must connect Pin1 and Pin3 of the Extender Module. I didn’t do nothing of this. Once I started the upgrade software, I needed only to press the “Reset” button of CellularRadio module for about 2-3 seconds. Then the upgrade starts.

Thanks to all for help!


#13

Awesome news. The UART Dyslexia post probably helped then


#14

@ Bigfoot - well done. It pays off to keep trying :wink:

No reason to feel bad about dyslexia :wink:


#15

too true, although I’ll still be paranoid about it :slight_smile: But really all that means is if it doesn’t work first time, reverse the wires and see, and if it still doesn’t work then start debugging


#16

@ Brett - Yes, that post has been useful! :slight_smile:


#17

Unfortunately, after a week of SMS inactivity (no sent to and no received from SIM900) the issue has come back again.
so the firmware update doesn’t concern to this strange behavior.
I read about a “sleep mode” of SIM900 to reduce power consumption.

I verified these settings:

  1. functionality mode (AT+CFUN) and SIM900 sent “1”, so it’s set to “full functionality” mode;
  2. sleep/slow clock mode (AT+CSCLK) and SIM900 sent “0”, so slow clock is disabled and module will not enter in sleep mode.

I don’t know what else I can check.

What do you think/suggest?


#18

Hmm, I have no idea, and my attempts would qualify as hacking.

You could set up a web-server and initiate a network connection (PPP or native modem - depends on the mainboard) and then report with a simple HTTP-POST how it is going.

In this way you might keep the module alive, and at the same time have a report on your server to check how it is going…?

EDIT: Did some research, it seems that other people have problems after 1 week of inactivity, it goes into auto sleep mode. You will have to keep it alive in some way. Not sure what the easiest and cheapest way is…


#19

I made a simple test: send an SMS each 2 days and wait for the response.
the test is started last Sunday with the first SMS.
After that I sent an SMS on Tuesday, another one on Thursday and the last one today (Saturday).
Cellular radio has always responded except today (Saturday)!!

What does it mean??
Maybe it’s not an inactivity issue but a “time bomb issue” that has a timeout starting from the module power cycle?


#20

Can you share your code?