Main Site Documentation

Can't update tinybooter on Fez Spider


#1

Hi,

I’ve been trying to get .Net Gadgeteer working on Windows 8 for a while and I have one remaining problem - I can’t get the firmware to update. What happens is that when I run the config tool, it gets most of the way there and then fails leaving me with an erased .Net Gadgeteer. I thought it might be related to the tinybooter version (mine is 4.1.6 - or something like that). I’ve been looking at this guide and I can’t get past one of the steps:

https://www.ghielectronics.com/docs/54/firmware-update-emx#521

where is says “EMX: Press and Hold UP, Select and Down buttons then while holding them down press and release the Reset button.” … I have no idea what this means. I tried the page up/down keys and enter key but nothing happens. I can’t get any further without getting past this step.

Apologies for being thick, but can anyone help me get this sorted?

Cheers!


#2

Welcome!

That page has a specific section on getting the Spider ready for update.

See the image below on how to the get the hardware ready. After this is done, you can skip to the “Updater Application” section.


#3

Thanks!

It’s a Fez Spider 1.0. I’ve tried with those settings … it get’s about three quarters through firmware2.hex and then fails displaying a message about an interrupt in deploying.

I wondered whether updating the tinybooter would help, but I got stuck at that point in the guide.


#4

The EMX instructions (multiple buttons) are equivalent to the switches on the Spider kit.

The fact that you go through the update process but fail shows you’re using the right approach, but can you please let us know what the version information from your running (in normal mode) device says, from “Device Capabilities” option in mfdeploy.exe? That way we can validate that the firmware is or isn’t consistent. You can try the “legacy” firmware updater from the support page too, to help do all your updates easily.

The other way you can tell what mode a device is in is to look at your PC’s Device Manager; if in a bootloader mode, you’ll see a COM port, if running netmf normally you’ll see a debuggable .NET device.


#5

Did you use config toolV013,
I have similar problem for updating the tinybooter use toolV013.
Maybe try the Toolv003 ?


#6

Thanks for all the suggestions. I’ve tried the legacy updater and it can’t connect. It can ping the device but when I start the update it doesn’t complete.

Device capabilities in MFDeploy says ‘Not Supported’.

There is no firmware on the device as it was erased before the failed update. It’s running tinybooter 4.1.6.0.

It is never recognised in serial debug mode. I can ping it in usb debug mode and use fezconfig (the latest) to start the update process (which fails).

I really don’t know what to try next.


#7

Manual firmware update time. https://www.ghielectronics.com/docs/54/firmware-update-emx

You will need to start at the section “TinyBooter Update through GHI Boot Loader” and progress from there.


#8

Actually I got it to work. With much plugging and unplugging of usb cables I got one of the legacy uploaders to update tinybooter, then I used the newer Fez Config to get the firmware up to the latest version.

So far so good.

Thanks everyone for your help and advice!