Main Site Documentation

Can't Update Firmware on Fez Domino


#1

Hey, so I have 2 Domino boards. Been using the one for a while. Bought a new one, and when I went to update firmware realized there was a new version of the sdk.

I tried your new updater app, it said it updated successfully.

But after the update it said “Version: Unknow” (yes it was missing the n)

I updated again just to be safe, same result, but it said successful.

But when I tried to use the device visual studio can’t see it.

Turns out it’s still in bootloader mode, and now it won’t boot out of bootloader no matter what I do.

So I tried the old method (terraterm xmodem upload). But when I do that method it does the xmodem upload, says successfully finished, but then says “Bad firmware” and returns to the BL prompt…

I’ve re-installed and re-downloaded the sdk twice now, and getting the same thing…

Problem is when I discovered this I updated both devices. And both devices are now doing the same thing.

Help! :slight_smile:

Thanks!

Update:
Windows 7 X64 Ultimate
I’ve re-installed the drivers from the sdk, no help.
Using the latest version of the sdk downloaded direct from the GHI downloads page today.


#2

Try uploading the firmware using MFDeploy.


#3

Try to use a power pack when updating the firmware.


#4

By any chance are you falling into the trap where the file can’t be correctly read when you don’t run with appropriate permissions? Run as Admin and try the upload again (in either tera term or the uploader)

Oh and hi, welcome to the forums ! :slight_smile:


#5

I just tried using an external power source (7.5V several A) and it made no difference.

Also I tried reflashing using the external power using the fw update app, and through terraterm (made sure both were running as admin) made no difference, same results.

I can’t find MFDeploy anymore on the new version of the SDK (I used to have it on the old one, but can’t find the binary anymore).

Anyway, here is a log of the install from the USBiziUpdater.exe (at "Updating Firmware. Please wait… a progress bar appears and runs through as normal, then at the second “rebooting” it sits for about 20seconds before proceeding)

Log:


-- Log --
Connecting to device... 
USBizi found at Port#: COM2
GHI Bootloader Version: 1.07

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erasing... 
Erase successful!
Updating Firmware. Please wait... 
Rebooting...
Disconnecting COM2
Rebooting...
Firmware updated sucessfully. Version number: Unknow
Updating Firmware is done! 

The xmodem stuff also works as it always did, No problems in the process other than Bad firmware at the end.

Here is a log from the terraterm session:


Switch to 921600?
BL
1.07
BL
Start File Transfer
CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
File Transfer Finished Successfully
Bad firmware
BL

During the transmit stage I’m using XMODEM of course, in 1K transfer mode, progress pops up as usual and runs through 100%, no problems there, but then “Bad firmware” as you can see.

The firmware file I’m using is at:
C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USBizi\Firmware\USBizi_CLR.GHI

As I said I’ve reinstalled several times, and also run a “repair” install. Plus re-downloaded.

I’m at a loss here, I realize my fez’s aren’t crippled as the bootloader is still easily accessible, but I can’t very well use them in this state.

Thanks!

  • Paul

#6

I have only seen this happen when there is a bad power source or the firmware file being loaded is corrupted.

Check if the firmware file you are loading is zero bytes!


#7

File Size is 338 KB (346,112 bytes) according to windows.

Power source for my current application circuit is a fairly high end 2S (7.4V) lipo battery, fully charged. Currently outputting closer to 8V under no load. So the PSU isn’t at fault. Though I can try it with a few wall warts too.

Do you have a known “clean” source for the firmware file that I can download directly? Perhaps my computer is doing something silly to the file during the install of the SDK? (AV soft, or something, god knows) lol

Thoughts?

(Also thanks for the prompt replies. I have 2 projects due on thursday that both rely on these boards lol).

  • Paul

#8

Did you download tera term from our website?
Place the firmware file on your desktop and try again. Maybe windows is locking your “program files” folder!

no go? Try this maybe http://www.ghielectronics.com/downloads/NETMF/GHI%20NETMF%20v4.1%20and%20.NET%20Gadgeteer%20Package(Oct%207th%202011).zip


#9

I’m pretty sure terraterm is from your website. It’s the same version I used to install the firmware on my first fez last summer. But It’s been a while.

I tried the file you linked and no go…

But I did (at your earlier comment on teraterm) look for the GHI download of teraterm and re-download it direct from GHI…

That seems to have solved the problem. Not sure what was different about the version I was using, but it made a difference.

Seems to be working now!

Thanks for all your help!

  • Paul

#10

Did you extract the GHI installation files from the zip file before you did your installation?