Main Site Documentation

Can't update Cobra 2 Staying in bootloader


#1

I’m trying to update a cobra 2 to the latest firmware with rhe GHI update tool.
the board is staying in bootloader even though i am not pushing the loader buttons.
I updated a different board with no problems so my setup is ok.
any thoughts?
Can i get a RMA and exchange the board?


#2

Did you try to connect to it from a terminal software?

V for version
R for run
X to load tinybooter

You can contact GHI directly for RMA please http://ghielectronics.com/contact


#3

it just responds with BL no matter what i type


#4

Upper case


#5

V-1.01
R- BAD FIRMWARE
X - START FILE TRANSFER
then lots of CCCCCCCCCCCCCCCCCCCCC


#6

Once the Cs are on the screen, you need to need to activate X-modem file transfer protocol to transfer the file. Follow these instructions once you have the Cs: http://www.ghielectronics.com/docs/54/firmware-update-emx#521


#7

tried it
it has been stuck @ 0.3% for a long time.


#8

update
i didn’t have the IK selected
went through now but it is still responding with BL


#9

Last thing to check is your power source. You need a powered hub or a power pack.


#10

i am on a powered hub and i plugged in a 12v 1amp powersupply


#11

Time for RMA :slight_smile:


#12

sent email in contact us
thanks


#13

I may be having a similar issue:
Brand new Cobra II, first thing I did was attempt to update it.

First I ran FEZ_Config_v011: found the hardware, but got errors updating.
Then I broke down and read the documentation & related forum posts…
I figured that I needed to update the TinyBooter:

  1. Plugged in a 12v 1a power supply, in case that was the issue.
  2. Booted into TinyCRL mode (reset while holding LDR1)
  3. This allowed me to connect with TeraTerm on COM9
    BL
    b[/b]1.01
    BL
    b[/b]Erase all memory! Are you sure?b[/b]
    Erasing…


Done.
BL
b[/b]Start File Transfer
CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
(Transfer:XMODEM:Send:C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G120\Firmware\TinyBooter\G120_TinyBooter.GHI (1K))
BL
File Transfer Finished Successfully
BL
b[/b]Bad firmware
BL

Now FEZ_Config_v011 can’t even find the hardware. Am I picking the wrong TinyBooter.GHI?

The PC does detect the USB in each of the 3 modes (reset/reset&LDR0/reset&LDR1): I hear the disconnect/connect sounds.


#14

What does Device Manager show when the connect sounds play?

“Bad Firmware”. I suggest you re-install the GHI SDK to get another copy of the firmware, and make sure you run the installer and firmware updater as Administrator.


#15

In the “broken” state: GHI Boot Loader Interface (COM9) - no matter what buttons get pressed during boot

I fixed it. I was lucky that I had and old copy of the GHI SDK on my other PC (11/29/2012). I ran the G120 updater and it worked with no problems.
OK, now it is at:
Connecting to device…G120_G120
Loader (TinyBooter) Version: 4.2.7.0
Firmware (TinyCLR) Version: 4.2.7.0
Running FEZ Config’s Firmware Updater to bring it up-to-date fails (because the Loader is not 4.2.10.0 I assume).
Tried to update the Loader again using tera-term & it resulted in “Bad Firmware” again.

Well, the old G120 updater seemed to work… so I ran that using the TinyBooter & Firmware files from the 4/30/2013 release and it worked.
Now FEZ Config reports:
Loader (TinyBooter) Version: 4.2.10.0
Firmware (TinyCLR) Version: 4.2.10.1

I think I am good now.


#16

@ eolson -

great!


#17

I had a nearly identical problem with my G120. Instead of using the old GHI firmware updater program, I updated TinyBooter and the GHI firmware manually using TeraTerm and MFDeploy as outlined in these steps: http://www.ghielectronics.com/docs/54/firmware-update-emx#521

Since the above procedure applies to EMX, some of the buttons that need to be held down should be modified for the G120 as follows:

LDR0 Low + LDR1 Low = Boot until GHI Bootloader level
LDR0 High + LDR1 Low = Boot until TinyBooter level
LDR0 High + LDR1 High = Boot normally until application level

FEZ Config (Beta) currently can’t update devices that have an older TinyBooter version. Updating firmware using the beta program appears to create this problem, requiring manual intervention.


#18

FYI: we’ve added a link to the legacy firmware updaters to our Support .NET Micro Framework page http://www.ghielectronics.com/support/.net-micro-framework


#19

@ MikeCormier -
I am also stuck on 0.3% what is the “IK” you mention ?


#20

Hi Zarzel, welcome to the forum - pity you’ve got a problem, but welcome none the less

It is 1k not IK, it’s the little radio button on the file transfer dialog. Have you tried the legacy Fez Config tool from http://www.ghielectronics.com/support/.net-micro-framework ? Please try that and confirm what it reports.