Main Site Documentation

Can't select mainboard in Visual Studio


#1

I have followed all the steps but I can’t create a Gadgeteer project since I can’t select a mainboard.

For all mainboards it just says
"This board requires .Net gadgeteer core version 2.42.500 or newer"

I have downloaded and installed the latest version of the core (2.43.800)

Tried to uninstall everything and reinstall it but I still get the same error message.

Tried both C# and VB.Net projects.

Windows Vista
VS2010 Express (both C# and VB.Net)


#2

Hello adrianm. So you have installed GHI SDK (https://www.ghielectronics.com/support/netmf/sdk/8/netmf-and-gadgeteer-package-2013-r3)? If you did, then open Program.gadgeteer in you Gadgeteer project and check if there is any board on. If it is, you can remove it. Then open Toolbox and check your board.

I hope it helps.


#3

The 4.3 core only works with vs2012

Read support pages carefully


#4

Thanks. I am new to this so I don’t really understand how all version numbers work together yet.

I installed an older version of the core 4.42.700 and it works better. I don’t get the mainboard dialog at all but the project is created and can manually add the mainboard to the designer.


#5

The mainboard dialog was implemented with the MS 4.3 SDK and VS2012. It does not appear with the MS 4.2 SDK.


#6

I could be wrong but I remember this is a feature added in latest gadgeteer SDK, works on 4.2 and 4.3?


#7

You do not need the core, you need our package, which includes the core. Did you install our latest package 2013 R3?


#8

The OP was trying to use VS2010, which is not supported by a SDK with the mainboard dialog.