Main Site Documentation

Can't Ping CodeworkX Development System v1.2 via Network


#1

Hi!

I used MSDeploy.exe to give my board an ip adress. I took 192.168.2.1. On my PC I took 192.168.2.2 - but I can’t ping the device - why? The IP Adress is also shown on the LCD display - but the ping works in no way.

Do you have an idea how to solve this?

Btw - I’m getting a timeout for the ping…

Regards, Andi


#2

Do the board and the PC have the subnet mask (probably 255.255.255.0) and the same gateway? Hm…also, not sure how your netork is configured, but .1 is generally what your router would use. Is the board plugged into the router or the PC?


#3

If you are connecting the cable directly between ChipworkX and Your PC, make sure that you don’t need a cross-over cable. To make sure it is not the reason, just connect it through Ethernet switch.


#4

Hi!

Up to now I do not use a router/switch - I try to connect it directly to my notebook. I tried with a straight and a crossover cable - both is not working.

Greetings from Austria :wink:

Regards, Andi

EDIT: A short overview over my config:

CodeworkX Development System v1.2:
IP: 192.168.2.1
Subnetmask: 255.255.255.0
Std-Gateway: 192.168.2.254

Notebook (Lenovo Z61m, Windows 7, Firewall Off, Static IP):
IP: 192.168.2.2
Subnetmask: 255.255.255.0
Std-Gateway: 192.168.2.254

The Std-Gateway does not exist in the network, but i don’t really need it I think…

They are connected through cross-over or straight-through cables, both is not working. I’m getting a timeout when I’m pinging.


#5

How are you pinging using MFDeploy or a command prompt?
You should use a command prompt.


#6

Remove the Default gateway from your PC’s network interface and remove the gateway from ChipworkX.

That is because in Windows 7 we noticed that it first tries to find the assigned gateway then it blocks the interface if it is not there.


#7

I’m pinging from the Win7 command prompt.

I’ve removedthe default gateways, but it’s still not working. Have anyone of you tried a direct connection from ChipworkX to a PC running Windows 7?

Thanks


#8

Yes we did try that.

Please take a look at the Ethernet connector at ChipworkX. are they on when you connect the cable?


#9

You mean the green LED? Yes, it’s on! And the orange LED is flashing sometimes for a short while.

Regards, Andi

EDIT:

I’m so stupid --> 192.169.2.2 on my ChipworkX and I didn’t see it checking it every 10 minutes…
waaahhh :slight_smile:

Thanks to all!