Main Site Documentation

Can't find GHI templates when creating new project


#1

I have been trying to install Visual c# 2010 with netmf on a new computer. I installed this software about a year ago on another computer and had no problems, but this new installation is giving me headaches.

I installed the software using the links on this page:
https://www.ghielectronics.com/support/.net-micro-framework
I did steps 1 to 3 on the 2010 side and tried to create a new project.

“File- New Project” brought up the “New Project” Screen. I selected “Micro Framework” and “Console Application”. Then I noticed that there were no templates for the GHI boards. I could not figure out how to select the Panda 2 board that I wanted to work with.

What have I missed? I am certainly no expert, just a casual user who likes to tinker. Do not be reluctant to talk down to me; I need a simple response. I could not find the answer in the fora.


#2

Do you see the Gadgeteer Template?


#3

Here is what I get when I click on “File-New Project- Console Application”. Below is the image…


#4

Templates were removed long time ago. Only gadgeteer has templates now. We recommend you start with the console project.


#5

Hi Ron, welcome to the forum.

yep, as Gus said, what you see there is EXACTLY the correct view. The only thing the specific templates did was add the correct reference for the hardware, which is only a quick click or two away anyway, so not a significant loss (in my view). Hopefully that’ll reassure you that you have everything correct. [ I did notice you didn’t have the Gadgeteer template so you mustn’t have installed the Gadgeteer SDK portion, was that deliberate? If you don’t have a Gadgeteer mainboard it might still be worth installing it, unless there’s no chance you’ll ever get one. ]


#6

Thank you for all of your replies.

I first installed VC#2012. I used the files at “https://www.ghielectronics.com/support/.net-micro-framework” and the Gadgeteer templates did show up- they were very impressive. But I have a Panda 2 board and the expected templates did not show up, so I uninstalled 2012 and went with VC#2010, using the files indicated in the picture.

Now both the Gadgeteer and the expected old-style templates were gone, and I got confused. The old template for the Panda 2 added “using GHIElectronics.NETMF.FEZ” to the program.cs file. I could not find this reference when I tried to add it and when I typed it in I got the wavy red line under “GHIElectronics”.

So, how do I add the correct references for a Panda 2 board? How do I get the Gadgeteer references back? Is there a tutorial that specifies them? “First NETMF Project” uses the old references that I was used to. I have missed something, but I do not know where to look any more.


#7

If the packages are installed out of order (ie if you re-install visual studio, you must start completely over with step 1) then things will not work right.

However, for the Panda 2, you will need to download the optional 4.1 package from the Support -> MicroFramework page. This will give you the templates for 4.1 boards.


#8

That did it! Thank you. I did not realize that the Panda 2 was a “legacy” product. I assumed that the new SDK would be backwards compatible.

All good now.


#9

Thanks for this info! I didn’t spot this either.