Can't connect to FEZ SPider after upgrading to the last GHI SDK (2015 R1)

Hi there,

My FEZ spider was working well with windows 10 but aftter installing the last GHI SDK and a failed Firmware update I can’t connect anymore to the board.

After trying to install win 10 from scratch, windows 8.0 and 8.1 the message is allways the same (little yellow traingle in device manager) and trying to connect from FEZ Config shows me the image bellow.

Any help?


Didn’t you forget to restore DIP switch positions after TinyBooter update?

Hi Simon,

Actually I did it but it doesn’t work I also did the firmware update with FEZ Cerbetus and I can’t connect as well.

Thanks for your quick response.

I have a similar problem which only seems to affect the Spider (I’ve managed up update CobraII’s and a Raptor without issue).

Windows 10 shows the device but with an error 10 (cannot start error). This was the same on both my main desktop and laptop. After uninstalling the GHI SDK, reboot, reinstall I managed to get it working on the laptop. The same ‘fix’ isn’t working on the desktop though.

Hi Andre,

It seems that connecting the board to an USB port show the image bellow. The problema is when I install the GHI Electronics 20015 R1 it inmediatelly put the Little yellow triangle and the erro code it shows is the 10.


Hi Andre,

I changed the language, and I got the same result. Where can I find the EMX driver for the USB?. Is there an way to upload the driver manually?



I tryed to prevent the fail and made a restoration point before installing the GHI SDK 2015 and after restoring to the last restoration point I see the Port available and working but the EMX driver not installed.

Hi there,

After trying a lot I reach to the conclusion that the problem is the current or voltage that feeds the board. Trying to put the board in the uploader mode sometimes I can see the Device Manager with no problems at all but as soon as I press the reset button on the board, the little yellow triangle reappear some times, and other times an error about tryin to install a wrong usb driver shows up.

What is really a problem is that this system works before perfectly until I tried to update to the last SDK. Is there something I´m not looking at?. Somebody has the last software about three or four moths ago? I mean all the software so I can try it again. Cans somebody tell me the real power pack specification jus to turn on the Fez SPider 1.0 and the USB DP power unit?.


a Spider, with no code on it, and with only the DP module connected, will run fine on 500ma power coming from USB.

I still think your issue is the driver. We need to find a way to force your driver update. Do you have another PC ?

Hi Brett,

Yes!!!. It was the firmware update. I updated it using FEZ COnfig even at that moment still had the yellow triangle, I did the update putting a 12V 1 Amp Power Pack to the board with the board and the DP alone. Thanks for your help!.

Adittionally, all this stuff was because I was trying to update to the new SDK to solve the problem of not working outside VS. And fortunatelly it is working now!!!.

Thanks again.