Main Site Documentation

Can't change the IP of EMX with Deployment Tool


#1

I want to change the IP of EMX to pass my network, but It happens somethingwrong after clicking “Update”(see picture).

The framework and SDKs are latest.

I don’t understand it, how can I resolve the problem, can you help me.


#2

@ andre.m -

where can I find ghi’s tool?


#3

@ andre.m -

Thank your for your answer!!

I get a problem again (see picture).

I always got the error “Invalid MAC address”, but the content of network configuration in ghi’s tool is same as the network configuration in ms tool that I wrote before. why?

Is there a tool for converting between IP and MAC address?


#4

@ andre.m -

where can I see my MAC for my network?


#5

google MAC address to get a better understanding.

each device on a network has a unique MAC address. you can generate a MAC address at http://www.miniwebtool.com/mac-address-generator/

your EMX module should have a label on it with a unique MAC address. GHI devices with built in Ethernet come with a MAC address.


#6

I want to repeat the way to set the network configuration. Maybe I had some mistakes in setting the configuration

step 1. Connection->Refresh List->Ping, I can see Ping… TinCLR from "Basic Information"
step 2. Network Configuration -> Load-> Network1-> typing my configuration for my Network(see picture 1)

In step 2, I tried many times MAC Address. I find that I can’t write any other MAC Address, I can only use the default MAC Address “0.33.3.0.0.1”, otherweise I can’t apply the configuration.

step3. Apply->“Network configuration has been saved successfully”. (see picture 1)

I have set my EMX as “192.168.178.204”, my Gateway is “192.168.178.1”.(see picture 2)

I use the programm “Wireless Network Watcher” to check my network, but I can’t see my EMX in my network. (see picture 3)

I have also “ping 192.168.178.204” in cmd window, but I got “Destination host unreachable”.(see picture 4)

I am confused about it. My webserver ran well with the same network configuration in MFDeploy - Shortcut, but now I can’t find my EMX in network with the same configuration setting in GHI’s Tool… I am very sad…


#7

@ workhard10 -

It looks like GHI tool only accepts Dec number, so try convert from Hex to Dec first.


#8

@ workhard10 - The image from the GHI program shows DHCP has been checked. How are you activating the static address?


#9

Where should I write in DEC?

I have written all configuration(Static IP Address, Subnet Mask, Default Gateway…) in DEC.


#10

I try again without activing DHCP.


#11

@ workhard10 - You will need some software to select the onboard Ethernet interface as the active stack.


#12

no, still not successfull… I have tried it and ping “192.168.178.204” (see picture 1 and 2)


#13

Can you give me a example about selectting the onboard Ethernet interface as the active stack?

I have no idea how to write the software, thank you!


#14

thank you, I check the codeshare.


#15

I set the static IP with software and it works now. thank you for your help!

Why is GHI’s tool for setting IP not successful?


#16

@ workhard10 -

what is the software you are using?


#17

I used the software tool(see picture) for setting static IP of EMX, but not successful.

After discussing with you I can use some codes in my project to set static IP of EMX.

I remember that I can always use “MFDeploy Tool” for setting static IP before updating to Micro Framwork 4.2

I’m very curious about he software tool(see picture).
what’s wrong with the software tool(see picture), or is it my hardware problem?


#18

@ workhard10 -

But the problem here is if you are using EnableStaticIP(…) and you passed an IPAddress in there, everytime firmware reset, your C# application will run again and it go back this ip address.

So although the GHI tool saved new ip address, but it requires to reset, so your C# application will run again and go back with the older value which you passed in EnableStaticIP.

If you are using dynamic IP address, this value is not effected.