Can't build .NET MF for STM32F1

@ Justin, I’d love to see 4.3.1 one by Oberon :wink:

The Oberon 4.3.1 port works extremely well from the little 48 pin 401 right up to the 429Disco boards with external ram. I would think the port will be released soon…

@ Justin - it’s really good news. Hope to see it published soon.

You say it runs 48-pin little one? Does it mean that it will run on STM32F103CB (the MCU inside Spark, the tiny WiFi dev board - )?

No, the spark is too light on resources to run netmf.
I am talking about the 48 pin F401 like used on this board
People coming to the UK workshop in July will be seeing something like the Spark…But…Better :wink:

1 Like

I’m stuck again :-[
Board still not recognized in Windows (Can’t configure USB). Tried to flash my led blinky app (both .exe and .pe files) at 0x08042000, no luck.

Firmware stuck in the loop somewhere around CLR_RT_ExecutionEngine.DebuggerLoop or CLR_RT_ExecutionEngine.WaitForActivity (as least what I see when debugging in uVision with tinyclr.axf assembly).

No idea what’s happening and what to do next. Anyone?

Finally got USB up and running! Device recognized in MFDeploy

Pinging... TinyBooter

It was USB attach pin…

1 Like