Main Site Documentation

Can't add custom class library DLL to the project references


#1

Hi everybody, i have a simple problem, thought. I’ve created a class library project and now i have my dll file ready. I can add this library to the project in the solution explorer and also i can compile the project but when i try to start debugging i get an error message that says that it’s a problem with the hardware :o

I tried to add only de class “.cs file” and all works fine so i think the problem is in the dll assembly.


#2

Does your firmware match the sdk?


#3

I’m watching this thread because I’m having this exact same problem with a Hydra project. I tried re-creating the project, restarting everything. Nothing works. The assembly worked fine in a Panda-II project but it will not deploy to Hydra.


#4

Did update your hydra to latest firmware?


#5

I’m still using the latest from the last package install. Should I try the CodePlex version?


#6

Hi again, now i’m debugging the project using the emulator instead through the usb connection, when the dll reference is in the project i get the message - Assembly file " does not exist! Load failed.
And when i remove it from the project references the code runs well in the emulator.