Main Site Documentation

Cannot update FEZ Hydra firmware: Device is not connected or not responding


#1

Update 1:

Hi friends, could you please recommend me a powered USB hub in Australia(preferred in Melbourne)? I guess my problem is caused by the insufficient power supply.


Dear all,

I have a FEZ Hydra Basic kit. I got it in 2012 (might be in Sep).
Today I downloaded the latest SDKs, drivers and everything(NETMF and Gadgeteer Package 2014 R1). (.NET Micro Framework 4.3 and the firmware I have on my laptop is 4.2.6.2)

But the firmware on my deivce is 4.1.x.x(I was lucky to saw the device’s firmware version just once and I followed the instruction on the software FEZ Config, but failed with errors).
After that, I cannot get the Device’s firmware version any more.

I found changing USB ports sometimes help. I have 4 USB ports, some of them can connected to the device, others are not.

So I have no idea to update the firmware in other way.

Could someone please help me to figure out how to find a way to update my firmware?

In the attached image, it shows: the FEZ Config detected the FEZ Hydra and was trying to get the device’s firmware version, but it failed to do so and followed by an error message say: Failure - Device is not connected or not responding.

As I mentioned above, I was lucky to see the FEZ Config successfully got the device’s version only once.

So my guess is - is it because the output power is not strong enough to support the operation, so I have to use something like a USB hub which has a strong and stable power?(I saw someone mentioned this and cannot find the comments any more).

Bt the way, all USB ports I mentioned above are directly on my laptop which means they get power directly from motherboard, so they should have strong and stable power to support my operations.

I have been stuck at this issue for the whole day, I really hope some friends can help me out.

Thank you very much in advance.


#2

Could anyone shed light on my question?

No even need to be an answer, as long as giving me some feedback, so I know what is going on.

Thanks a lot!


#3

Aha, some more info. Hopefully you’ll have enough from your other threads. I have a hydra I can loan you if you want, tell me what SDK version you installed and i’ll update it before I send it. PM me your details and I’ll ship it this week, or if you want to ship me your hydra i’ll update it and send it back.


#4

Hi Brett,

Before saying anything, I’d love to say a BIG THANK YOU for your willingness and help.

I have sent you my postal address and my email.

Please let me know if you saw my message .

I am looking forward to your reply.

Best regards


#5

@ franva -

[quote]
But the firmware on my deivce is 4.1.x.x[/quote]

Hydra has 4.1xx?? if it does, it looks like very long time ago.
And on Hydra, FEZ Config only supports to update firmware. But it looks like you have to update Tiny Booter and Firmware to run 4.2.6.xx

try with this link if it helps

https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra


#6

[quote=“Dat”]
@ franva -

Hi Dat,

Thank you very much for your reply.

I have tried that and it didn’t work either.
I am waiting for Brett’s components and see what I will be able to achieve.

Will keep you all posted.

Thank you for your help


#7

When you tried this:
https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra

What errors did you see? When you followed the directions in the section “Erasing Flash and Entering bootloader”, what method did you use?

If you were able to get to the section “Deploying Loader (TinyBooter)” what did you see in the device manager.

Aside from the above: you said that you have tried two different computers, what version of Windows were you running on the two computers?

NOTE: You must complete the directions in the above URL before you will be able to update the firmware (TinyCLR) using FEZ Config.


#8

Hi Jeff,

Thank you for your reply.
I have tried the first 2 methods to solve the problem. Yes, I did follow all instructions on there.
The errors I saw were:
Method 1 : Deploying a program to erase the Flash and xxx.
When debugging, it said cannot communicate with the device.

Method 2: connect pin 8 and 10 in socket 3.
It worked for erasing, but didn’t solve my problem. The same problem shows again after doing that.

Method 3: Cannot do it mate, I do not have a SD Card Reader.

The OSs I have tried on are : Windows 8.1 Pro and Windows 7 Home Premium.

Now, I have received Brett’s components and everything works like a charm!!! :slight_smile:


#9

I sent down my hydra and it works, so its the firmware update that’s the only thing having an issue it seems. We’re talking about if I should try to update Winston’s hydra to see if its a laptop thing or a hydra thing…


#10

Hi Brett,

Thank you for your help.

A good news is that I received all my components ordered from GHI today and will give a try to see whether I can upgrade my firmware through the new DP module.

I also really really would like to give a try of the Relay module, and I am thinking how to reduce the possible damages to the minimum.

Thanks a lot for your help and willingness.

Cheers,

Winston


#11

@ Brett -

Hi mate, I saw the Relay and Current modules, but how can I plug in my appliances(don’t worry, just some light bulbs) on them and then how can I connect the Relay and Current modules to power (They do not have the power jacks)?