Main Site Documentation

Cannot see FEZ Raptor


#1

Hey guys! I just received a brand new FEZ Raptor. I Also bought a USB Client SP module. I attached the module on port 8 of the raptor, and plugged the USB in my PC. A Red LED lights up on the Raptor.

Now, there’s no way I can see the device with my computer. The USB Recognition of Windows tells me it’s a ‘GPS Camera Detect’.

I Installed the following components :

  • Microsoft .NET Micro Framework 4.3 (QFE1)
  • Microsoft .NET Gadgeteer Core
  • GHI NETMF and Gadgeteer Package 2014 R5

If I start FEZ Config and configure whatever on the connection tab (i tried several combination) it won’t connect.

What can I do in order to connect to the device?

My Visual Studio btw, has all gadgeteer components. I can start a gadgeteer project and attach modules to it without a problem. However, running / deploying is impossible due to a connection failure.


#2

@ nikneem - Welcome to the community. For whatever reason, it looks like you received your FEZ Raptor without a firmware on it. Can you try to follow the update instructions in section 5.1 and 6.1 in https://www.ghielectronics.com/downloads/man/G400_User_Manual.pdf That should put the firmware on your device.

Did you purchase the Raptor through us or through a distributor?


#3

Thanks for your reply, I will try to add the firmware on the device and keep you posted. I bought the board and all modules on this website : http://www.antratek.nl/


#4

I Started the update.bat file from the \Firmwares\G400\Loader\ folder

The log file tells me :
-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA 2.12 on : windows
current connection is \USBserial\COM3, \USBserial\COM3 to be matched
-I- Retrieved arguments from command line :
-I- argv 0 : \USBserial\COM3
-I- argv 1 : at91sam9g15-ek
-I- argv 2 : Loader.tcl
-I- Connection : \USBserial\COM3 (target(comType) = 0)
-I- Board : at91sam9g15-ek
-I- Traces Level : 4
-I- target(handle) : 57829832
Read device Chip ID at 0xfffff240 — get 0x819a05a1
-I- Found processor : at91sam9g15 (Chip ID : 0x819a05a1)
sourcing device file C:/Program Files (x86)/Atmel/sam-ba_2.12/sam-ba.exe/…/tcl_lib/devices/at91sam9g15.tcl
sourcing board description file C:/Program Files (x86)/Atmel/sam-ba_2.12/sam-ba.exe/…/tcl_lib/at91sam9g15-ek/at91sam9g15-ek.tcl
-I- Loading applet applet-lowlevelinit-sam9g15.bin at address 0x300000
-I- Memory Size : 0x0 bytes
-I- Buffer address : 0x4
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- Low level initialized
-I- External RAM Settings : extRamVdd=0, extRamType=1, extRamDataBusWidth=32, extDDRamModel=0
-I- External RAM Settings : extRamVdd=0, extRamType=1, extRamDataBusWidth=32, extDDRamModel=0
-I- Loading applet applet-extram-sam9g15.bin at address 0x300000
-E- Error during external RAM initialization.
-E- External RAM access is required to run applets.
-E- Connection abort

I’m not sure if this is correct…

After this, i’m still not able to see the device in FEZ Config


#5

@ nikneem - It looks like your board is defective. I’ll contact you with information on an RMA shortly.