Main Site Documentation

Cannot load TinyClr on G80 like processor


#1

I got the Bootloader updated to v2.0.4, but when I use try to load the .ghi file using TinyClr Config Loader tab, it tells me that the .ghi file is corrupt. Downloaded it again, same result. If I try to connect to the device on the Debug tab, it will not connect. Are there some serial parameters in the driver that need to be set? I tried TeraTerm and it does not seem to download the file, the progressbar stays at 0%. Any help is appreciated.


#2

There is no “bootloader update” on G80! How did you update it and where did you get the instructions and the files?

http://docs.ghielectronics.com/hardware/products/scm/g80.html


#3

@Gus_Issa - Well, technically it is not a G80, just a Stm32f427 using the Cerb bootloader. If that is not the right approach, please let me know what is.


#4

Cerb is 12mhz. FEZCLR is 8mhz. Those are good starting point. G80 is not what you need.


#5

.ghi can only be loaded using the G30 or G80 processors. All other processors need to use the .glb file. You can’t load a firmware meant for one device using another’s bootloader. The Cerb loader can only load Cerb firmware.


#6

So it sounds like I need to create a custom port of TinyClr then, correct?


#7

It really depends what you’re after and what you need. The Cerb, G30, and G80 firmwares all require a 12MHz crystal while the FEZ requires an 8MHz one. What does the G80 firmware have that you don’t have in the Cerb firmware?


#8

@John_Brochue - This is a custom board using a STM32F427 (same as a G80), so I guess I could start with the G80 firmware and do a custom port…


#9

The bootloader is optional. You can run a device without it, you just have to place the firmware at the start of memory instead of after the bootloader, making sure to adjust the scatterfile and deployment locations as needed. Firmware updates will require using the ST tools, but the firmware will run fine.

You can do this by cloning the G80 and fixing up the addresses. You won’t need to do a full port.