Cannot fix error "An error has occurred please check your hardware" Fez Cerberus kit

I bought a Fez Cerberus board kit to get me started playing around with micro framework. Connected the device as the instructions said, USBSP to port 8, enc28 ethernet port 3, joystick port 4, and led7r to port 7. started a gadgeteer 4.2 project in VS2010 and get the error has occurred please check your hardware. Looked online and what i’ve read is that i needed new firmware for the ethernet. so i followed the instructions to STDFU Tester to erase the device adn reload it, then used MFDeploy tool to upgrade the firmware to the ethernet version. Anyways in VS i run the applicaiton and get the same error. i’ve also unistalled and reinstalled micro framework and gadgeteer core and the other applications from GHI but no luck. I’ve tried with the ethernet module removed adn also with all other modules removed and get the same error? i am running windows 7 on a parallels machine on my mac book pro not sure if that might have some effect but thought i would throw that out there. Any help is appreciated!

welcome to forum!
There are problems running OSHW boards with virtual machines. consider using Bootcamp.

Do you have any information in the output window in Visual Studio?. Please also make sure that you have selected your device for deployment inside the project properties.

I’m really very sure that’s the issue - my mate and I was trying and failing to get his cerberus working on the same setup as you, just would not come to life - but all 3 of my dedicated windows machines worked alright.


This has been discussed many times. At the present time, support for OSHW devices under virtual machines is partial at best. None of the vendors of MF boards have been able to get VM support fully working. I would guess it is not a high priority, since Bootcamp will work fine.