Main Site Documentation

Cannot Connect to PC


#1

When I plug the FEZ Domino into the USB I cannot get my PC to recognize the device (MFDeploy or ‘Tera Term). At one point in time I could ping using MFDeploy and communicate via ‘Tera Term from this PC. Suggestions?


#2

What had happened since you were able to ping? Maybe you have damaged the board somehow? Is the board getting hot?

Does windows make the “connect sound” when you plug it in?
Did you try to restart your PC?


#3

Yes it makes a normal USB sound (two low frequency beeps) when I unplug but when I plug it in I get an unusal sound (three faster low frequency beeps). I guessing I messed up the USB drivers on the PC. When I plug in without pressing the LDR button the ‘Device Manager shows ‘USBizi under the ‘Ports (COM & LPT) node with an ‘! yellow icon.


#4

The domino is okay. You need to reinstall the drivers

also erase and reload the firmware, just in case


#5

What is the best way to reinstall the drivers?

Never mind, I needed to reload the firmware. I think I am ok for now.

Thanks for your help.


#6
  1. Plug the device
  2. Go to WIndows device manager.
  3. look for the plugged device in the list.
  4. Right click
  5. Click Uninstall, choose to Delete the driver software for this device. Wait till windows is done.
  6. Unplug the device.
  7. Plug it again and follow FEZ tutorial to install the driver.

#7

I couldnt figure out why the ‘Debugable .NET Micro Framework Device wouldnt show up in my ‘Device Manager. It was because I had erased the firmware.

Thanks again.


#8

I am having a similar problem…my PC does not recognize my FEZ Cobra when I connect it via USB. The PC does not make any USB device detected sounds or anything, and it does not appear in MFDeploy. I have no problem when connecting an EMX development system. I have installed the 32-bit USB drivers manually using the downloadable installer, and have restarted the PC after installing the drivers. I also tried powering it externally with a 6 VDC power supply before connecting it. None of this worked. I am running 32-bit Windows 7 Ultimate. Any ideas?


#9

Is the power LED on? Can you try it on a different PC? Maybe your FEZ Domino is sick and needs a doctor :slight_smile: