CanDW on Cerberus Board "extended ID doesnt work!"

hello people, this is me again!

im having a weird issue with my cerberus/canDW arrangement, it is very weird because everything “seems fine”, but the point is that the receiver part gets only a partial arbitration ID, i mean, it only receives 3 bytes
(yes im aware it looks exactly as if i had left “IsExtendedID=false” but im sure i didnt…)

actually to make some desperate trials i used a ping timer… and a message that is in the examples:

void xCANPingTimer_Tick(GT.Timer timer)
            ControllerAreaNetwork.Message CanMessage = new ControllerAreaNetwork.Message() { Data = new byte[] { 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08 }, ArbitrationId = 0x12345678, Length = 8, IsRemoteTransmissionRequest = false, IsExtendedId = true };
            Debug.Print("CAN ping out");

and in the end the received side (Pcan Sniffer) receives only 678h as ARbID and the rest of the message perfectly fine, i tried sending from the sniffer to the gadgeteer board, and it does receive the complete ID, so im not really sure whats happening in there, anyone has some ideas?

PD: in the attached immage you can see the output pof the sniffer software for both… what it receives and what he sends!
thanks a lot

a small Update,

I used a logic Analizer and the result confirms that only a Standar identifier is sent as you can see in the attached image

the code is still the same

@ Ingcuervo -

Hope this help!

1 Like

@ Dat - Thank you, it’s a shame that this happens, i hope it can be fixed soon, anyway ill try to use the proposed solution.

this is why i tend to wait months before updating to newer versions of anything :smiley:

happy developing to all !

@ Dat - hello,
im not in this project anymore, but someone asked about this issue, i found the info in y old thread… but the link doesnt work anymore, any idea why?


@ Ingcuervo - The issue that required that code share should be fixed in the 2016 R1 Pre-Release 1 SDK.