Main Site Documentation

Can not send email from Spider


#1

I have a Spider with a J11D module.

Up until 4-5 days ago my project was sending emails with NO problem. Now that has stopped.

Last week I had to change a setting in my email program (Windows Live Mail) so that it could continue to work.
The new setting was to set the server requires a secure connection and change the port to 465.

I have tried sending via yahoo.com, att.net, gmail.com and gmx.com and none of these works. I have tried using different ports including 25, 465 and 587.

I have tried using BanskySPOTMail, Toolbox.NETMF and another I found on the net.

I’m hoping to find someone that has as their ISP, att.net and has a working project sending emails from a Gadgeteer.

Note:
To get Toolbox.NETMF to even start sending without throwing an exception was to download SMTPClinet v4.3 and compile it directly into my project in place of using SMTPClient v42.


#2

A Change of the port usually means that a different protocoll/authentification is used.
Port 465 is usually used when SSL is needed. Does your Client on the Spider Support SSL?


#3

After 20 some years in software, I never had to deal with internet, email, sockets or any of that stuff.
So I’m not sure if the client I’m using does SSL. Not sure what to look for in the source code for SSL.


#4

Have a look at this:
https://www.ghielectronics.com/community/forum/topic?id=4832
Did’t read in Detail, but Looks like it’s possible.