Building FEZ Hydra TINYCLR

Hello,

I’ve managed to build the CLR for the FEZ Hydra, re-flashed the board and I can write
simple programs that deploy and run fine on my Hydra board.

However as soon as I reference the GHI.Hardware assembly I get:

Assembly: GHI.Hardware (4.3.7.10) ***********************************************************************

  •                                                                 *
    
  • ERROR!!! Firmware version does not match managed code version!!! *

  •                                                                 *
    
  •                                                                 *
    
  • Invalid native checksum: GHI.Hardware 0x9E02C59C!=0x452A2614 *

My question is - is it normal to have the assembly checksum different between the released version and the hand built version?
(assuming I have not made any changes to the code)

Is the GHI.Hardware assembly built as part of the CLR build and if so where is the build version put?
(I cannot find one in the BuildOutput tree).

I should mention I am not referencing Gadgeteer, just plain netmf
and the original source code:
ghi_elect-netmf-open-firmware-e6b61b5b48c5.zip

thanks

That firmware message is often a problem when you created the new console application and don’t target the correct version of the framework (it will default to 4.2), so create a new project, check that you select 4.3, and try again. (I have a suspicion though that the GHI open port doesn’t have the GHI.Hardware additions so you will not be able to resolve this warning). Oh, and are you actually using 4.3 or did you attempt to build 4.4?

Hi Brett,

Yes it is 4.3 (I double checked)

Like I said, small programs work fine, it seems only when I add a reference
to GHI.Hardware (or any other assembly that refers to it) I get the warnings
and fails to deploy.

I did create a project from scratch, verified 4.3 and same result.
cheers

@ Dale Lyons -

Use FEZ Config → “Check Device for update” to make sure that your device and the PC has same firmware.
Remove all GHI references library and - re-add again!

4.3 has many sub-version. The important is 4.3.x.y. latest is 4.3.8.0

Fez Config is reporting for TinyBooter

4.3.7.7 on the computer
4.3.8.0 on the device

and for TinyCLR

4.3.7.10 on the computer
4.3.8.0 on the device

Ok, problem solved.

I had installed the latest stable release of the GHI sdk (3.4.7.7) however the
porting kit was referencing the beta build of the GHI sdk (3.4.8.0)

Once I installed the pre beta version all was good.

thanks for the posts!
cheers