Main Site Documentation

Breadboard X1 module


#1

I have the following:
FEZ Hydra (firmware 4.2.6.1)
SD Card
T43 Display
XBee

If I include an X1 module in my project, I can not run the program with or without debug. Using debug I get the Ctrl-Shift-F5 message and pressing Ctrl-Shift-F5 will only repeat forever. Trying to run the program without debug, the T43 display shows BUTTON QUEUE FULL and stops there.
If I take the X1 module out of the project, all runs and works fine.
I have setup the X1 for both socket 1 and 14 and get the same results.

At the current time, I have 2 X1 modules that I can not use.

Any ideas?


#2

are you saying that with a default Gadgeeter program, without any changes, you are having problems, or that you are having a problem while running your code?

are there any connections on the x1?


#3

The program I am using works and I had no problem running it without the X1.

With the X1 included in the program, the program would not start if using debug as I would be in a forever loop with the Ctrl-Shift-F5.

With the X1 included and not using debug, the program would never start as the T43 display would show BUTTON QUEUE FULL and stop there. I don’t know where the button queue full message came from as that is not part of my program.

Without the breadboard X1 included in the compile, my program runs and works fine with or without debug.


#4

does the same problem happen with a default program consisting of t43 and x1 with no code changes?

when you include the x1 with your program, does any code reference functionality on x1?


#5

OK, I created a fresh project and left the code default (did not add anything).
I included the T43, compiled and ran in debug and all worked.
I then included the X1 (T43 still included) and no work (kept getting the Ctrl-Shift-F5)
I then removed the X1 and all worked.

Like I said above, a fresh project with no code added by me.


#6

How is the board powered? And try to remove the display and try the relay?


#7

I removed the T43 display and added the X1.
Debug works.
Added the T43 back in and debug does not work.
Either the T43 or the X1 works but when using both the debug does not work.

Remember, I am still using a fresh project with no code added by me.

I’m using the USB client DP and there is a 2.5 amp power supply connect to it.


#8

What voltage is used?


#9

12V DC


#10

I’m running into the same issue with seed relay and cerbuino on socket 2…
not sure how related this is…


#11

I see that the problem starts in the file Program.generated.cs file when calling
this.display_T43 = new GTM.GHIElectronics.Display_T43(10, 11, 12, 13);
The debugger works up to that point but can never got by that point if the X1 module is installed.


#12

Ok we will test on our end and hopefully we can see the same behavior.


#13

one thing I tried before and it seems to help, unfortunately it can’t be applied permanently,

if you go to Program.generated.cs file and switch the initialization of the TF35 and Relay and move the relay to the first line… save and debug… don’t close the file or it will be overridden…

please test and report back.
thanks.


#14

In my case this did not work.

I was trying to use the breadboard Module X1.
I have found a way around the problem for my current project.
I have created two new classes: InputPinControl & OutputPinControl.
I have the X1 connected to socket 14 but I did not include the X1 in the program.
I can access the pins directly without going through the X1 class.
The program thinks the socket is not being used so you must make sure if a new module is added it does not go this socket.
You just have to watch what socket you use with the X1.


#15

I was able to reproduce the behavior with the BreadBoard module. It appears that it mistakenly includes references to Gadgeteer.SPI, Gadgeteer.Serial, and Gadgeteer.DaisyLink. If I remove those references any of those three references, I was able to get the program to behave normally.


#16

Thanks for looking into this.

Removing the references, is that something I can do or is it part of the dll?

Thanks again


#17

@ dcas - Just remove them from the references section of your porject