Main Site Documentation

Boot problem with G120SoM


#1

Hello!

I have problems to boot my G120 standalone. Plug in the power supply, my system doesn’t boot. After pushing the Reset button, everything works normal.

Now I found an table at the G120 Manual (Image)

My LDR0 and LDR1 are connected to GND by an pinheader. If a Jumper is set, the Pins are connected to GND, if not, the will float, like the schematic at the FEZ Cobra II.

Should i set a HIGH signal on LDR1 Pin 14 with an pullup-resistence to get into the right boot mode?

Thanks :slight_smile:


#2

Thank you andre,

unfortunetly it does’nt work. :frowning:
I give a high signal on LDR1 but the system just start. After an Reset everything is working fine. By the way. To get faster in the boot mode I connected LDR0 to LDR1. Is this a problem? Probably not, because the table told me that a High Signal on LDR 0 doesn’t care.

The FEZ Cobra also have no HIGH Signal on LDR1. How does it work? Is this a software problem? The new Bootloader and Firmaware are installed.

Thanks

Stefan


#3

@ Stefan, can you tell us what your device actually does when it boots ? Probably the best way is to describe what device appears in Device Manager in the different boot scenarios


#4

Thanks Brett,

The Pin 8 LDR0 and Pin 14LDR1 are internal HIGH on G120, so I don’t need to set a own HIGH Signal on this Pins.

I tried some things. I started the Device Manager and switch on the supply. LDR0 and LDR1 are HIGH (3.294V), but the Device Manager don’t show me the GHI NETMF Interface. If I press the Reset button on my device, the G120 will boot and I see GHI NETMF Interface in my Device Manager.

LDR0 and LDR1 set on LOW -> Power On -> Reset, LDR0, LDR1 to HIGH -> Bootloader on COM3 is loading in the Device Manager

So for me every importent state is running. The 3V3 Voltage are okay. I don’t know why I have to use the Reset Button.

Could it be a problem with my circuit?


#5

@ Stefan Kraus - Can you reflash the loader and firmware on the device and see if the issue persists?


#6

@ John - Yes I tried, but this didn’t solve the problem.

Maybe I can make a Hardware Reset at starting the G120
But my question is, which Capacity is on the Reset button at the FEZ Cobra II
This isn’t clear in the schematic. I use a 10n 0603 capacity. What does you use?

Thanks you!


#7

This is a part of my schematic


#8

My problem is solved. Now I’m using a 10uF 0804 capacity at my reset-button. This brings a longer LOW Signal to the Reset-Pin. The boot time is 1-2 second longer, but this is okay and it works fine. Now my system starts automatically.

Thank you guys for your help.


#9

We never needed this in our designs but your power supply had a long raise time.